Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today, I installed a fresh Ubuntu 12.04 LTS on my Sony VAIO VPCSB. I noticed a high cpu use of init and yes (as you can see below).

top - 16:26:16 up 11 min,  2 users,  load average: 2.71, 2.86, 1.82
Tasks: 183 total,   7 running, 176 sleeping,   0 stopped,   0 zombie
Cpu(s):  5.1%us, 33.4%sy,  0.0%ni, 61.1%id,  0.3%wa,  0.0%hi,  0.1%si,  0.0%st
Mem:   3962180k total,  1771012k used,  2191168k free,    47420k buffers
Swap:  4107260k total,        0k used,  4107260k free,  1028536k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
    1 root      20   0 24604 2528 1352 R   58  0.1   6:15.32 init               
 1197 root      20   0  4316  348  272 R   49  0.0   5:20.69 yes                
   60 root      20   0     0    0    0 S   22  0.0   1:24.63 kworker/2:1        
 2429 root      20   0     0    0    0 R   15  0.0   1:15.54 kworker/0:0        
   39 root      20   0     0    0    0 R    9  0.0   1:18.98 kworker/1:1        
 1845 root      20   0     0    0    0 S    6  0.0   0:40.58 kworker/3:2        
 1162 root      20   0  339m 106m  81m R    2  2.8   0:29.62 Xorg               
 1962 ingo      20   0 1116m 103m  59m S    2  2.7   0:11.16 compiz             
 1995 ingo      20   0  495m  16m  11m S    1  0.4   0:00.18 nm-applet    

Is there a solution?

Greetings

Edit: I took a closer look at the kworker

I found this Why does kworker cpu usage get so high?

$ grep . -r /sys/firmware/acpi/interrupts/
/sys/firmware/acpi/interrupts/sci:     729
/sys/firmware/acpi/interrupts/error:       0
/sys/firmware/acpi/interrupts/gpe0A:       0   invalid
/sys/firmware/acpi/interrupts/gpe17:     729   enabled
/sys/firmware/acpi/interrupts/sci_not:       0
/sys/firmware/acpi/interrupts/ff_pmtimer:       0   invalid
/sys/firmware/acpi/interrupts/ff_rt_clk:       0   disabled
/sys/firmware/acpi/interrupts/gpe_all:     729
/sys/firmware/acpi/interrupts/ff_gbl_lock:       0   disabled
/sys/firmware/acpi/interrupts/ff_pwr_btn:       0   invalid
/sys/firmware/acpi/interrupts/ff_slp_btn:       0   invalid

I am not sure if it is the kworker bug, still missing is the starting point of yes. Any suggestions how I could find it?

Now i tried to set up Ubuntu 12.04 fresh, and got a error message on the first start

package: fglrx-pxpress0.6~hybrid0.0.1

I really have no idea how to fix this, and excuse me, if i am missing something important here, just started with Ubuntu.


Picture from System Monitor with Yes process

System Monitor with <code>Yes</code> process

$ lsof -p 1182
COMMAND  PID USER   FD      TYPE DEVICE SIZE/OFF NODE NAME
yes     1182 root  cwd   unknown     /proc/1182/cwd (readlink: Permission denied)
yes     1182 root  rtd   unknown     /proc/1182/root (readlink: Permission denied)
yes     1182 root  txt   unknown     /proc/1182/exe (readlink: Permission denied)
yes     1182 root NOFD               /proc/1182/fd (opendir: Permission denied)

The try out Ubuntu works fine, I have no clue how to fix this. And it isn't possible to end/kill the yes process with the system monitor.

sudo lsof -p 1182
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/ingo/.gvfs
      Output information may be incomplete.
COMMAND  PID USER   FD   TYPE DEVICE SIZE/OFF     NODE NAME
yes     1182 root  cwd    DIR    8,1     4096        2 /
yes     1182 root  rtd    DIR    8,1     4096        2 /
yes     1182 root  txt    REG    8,1    22912  2622732 /usr/bin/yes
yes     1182 root  mem    REG    8,1  1815224 17301515 /lib/x86_64-linux-gnu/libc-2.15.so
yes     1182 root  mem    REG    8,1   149280 17301627 /lib/x86_64-linux-gnu/ld-2.15.so
yes     1182 root    0u   CHR    1,3      0t0     1029 /dev/null
yes     1182 root    1u   CHR 136,19      0t0       22 /dev/pts/19
yes     1182 root    2u   CHR 136,19      0t0       22 /dev/pts/19
share|improve this question
    
This happens all the time? –  LnxSlck Feb 4 at 17:25
    
yeah, it is a constant problem. –  WordIngo Feb 4 at 17:29
1  
$ sudo kill -s 15 1182 worked to end it, but after restart it is there again. And now it is confirmed that this is the problem of the high cpu use, after ending yes the cpu went down to a normal level. –  WordIngo Feb 4 at 22:36
1  
$ dpkg -S amd-xconfig fglrx-pxpress: /usr/bin/amd-xconfig seems like it connects with the error message pic i got on the first start of ubuntu @Sneetsher –  WordIngo Feb 4 at 23:07
1  
@Sneetsher Thank you very much, I will try this. –  WordIngo Feb 5 at 9:42
show 6 more comments

3 Answers 3

For me this has been solved automatically. I am running Ubuntu 12.04 LTS.

  • The problem first occurred - in retrospect - after an automatic update of fglrx-pxpress (0.3~hybrid0.0.1 -> 0.6~hybrid0.0.1) on 2014-02-04.
  • After the automatic update of again fglrx-pxpress (0.6~hybrid0.0.1 -> 0.6~hybrid0.0.2) on 2014-02-07 and never occurred again.

There is the bug entry if you want to know exactly what did happen: https://bugs.launchpad.net/ubuntu/+source/fglrx-pxpress/+bug/1277058.

And you may also want to delete some /var/log/upstart/amd-config.log* files, cause they contain mainly lines like that:

y
y
y
[...]
share|improve this answer
add comment

Thanks to this post and this one How do I get AMD/Intel Hybrid Graphics drivers to work? . I was able to fix this.

Starting today, I too had high init and yes CPU use. Killing yes would fix it till next boot. Using Sneetsher's instructions above (thank you!) I used htop to find out what was causing the yes process high CPU - it was amd-xconfig. Using the link I'm including above, I ran:

sudo apt-get install fglrx fglrx-pxpress

Rebooted and problem solved!

share|improve this answer
add comment

I had something similar just today - init running at 85% CPU usage and no idea why.

Running strace -p <PID of init> started spooling out huge numbers of errors about unable to get image from device buffer, and references to v4l.

Turns out I'd unplugged my webcam while the webcam software was still running, and it was causing init to really have a hissy fit.

strace should always be one of the first things you look at when you're trying to see what a rogue process is doing.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.