Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently upgraded my ASUS N550JV notebook from raring to saucy and in the beginning, simply installing nvidia-319 together with nvidia-prime worked fanstastically (as described here).

Shortly after the upgrade completed, I updated all my software sources and did a dist-upgrade, which somehow broke nvidia-prime. I have tried reinstalling it and installing a newer version of it. Nothing worked.

This is the relevant extract of my /var/log/Xorg.0.log:

[     7.636] (II) Module glx: vendor="NVIDIA Corporation"
[     7.636] (II) NVIDIA GLX Module  331.38  Wed Jan  8 19:10:17 PST 2014
[     7.641] (II) Module nvidia: vendor="NVIDIA Corporation"
[     7.643] (II) NVIDIA dlloader X Driver  331.38  Wed Jan  8 18:51:00 PST 2014
[     7.643] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[     7.647] (II) NVIDIA(0): Creating default Display subsection in Screen section
[     7.647] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[     7.647] (==) NVIDIA(0): RGB weight 888
[     7.647] (==) NVIDIA(0): Default visual is TrueColor
[     7.647] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[     7.647] (**) NVIDIA(0): Option "UseDisplayDevice" "none"
[     7.647] (**) NVIDIA(0): Enabling 2D acceleration
[     7.647] (**) NVIDIA(0): Option "UseDisplayDevice" set to "none"; enabling NoScanout
[     7.647] (**) NVIDIA(0):     mode
[     8.727] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20130102)
[     8.728] (II) NVIDIA(0): NVIDIA GPU GeForce GT 750M (GK107) at PCI:1:0:0 (GPU-0)
[     8.728] (--) NVIDIA(0): Memory: 4194304 kBytes
[     8.728] (--) NVIDIA(0): VideoBIOS: 80.07.9a.00.4b
[     8.728] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[     8.728] (--) NVIDIA(0): Valid display device(s) on GeForce GT 750M at PCI:1:0:0
[     8.728] (--) NVIDIA(0):     none
[     8.728] (II) NVIDIA(0): Validated MetaModes:
[     8.728] (II) NVIDIA(0):     "NULL"
[     8.728] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[     8.728] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[     8.728] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[     9.824] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[     9.824] (II) NVIDIA:     access.
[     9.829] (II) NVIDIA(0): Setting mode "NULL"
[     9.829] (EE) NVIDIA(0): Failed to initiate mode change.
[     9.829] (EE) NVIDIA(0): Failed to complete mode change
[     9.838] (II) NVIDIA(0): Built-in logo is bigger than the screen.
[     9.842] (==) NVIDIA(0): Disabling shared memory pixmaps
[     9.842] (==) NVIDIA(0): Backing store disabled
[     9.842] (==) NVIDIA(0): Silken mouse enabled
[     9.842] (==) NVIDIA(0): DPMS enabled
[     9.842] (II) NVIDIA(0): [DRI2] Setup complete
[     9.842] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia

And this is the /etc/X11/xorg.conf file that nvidia-prime generated on my machine:

# Warning: This file is autogenerated by nvidia-prime. All changes to this file will be lost.

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "1:0:0"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    # The internal display might not be connected
    # to the nvidia card but we definitely want
    # to be able to connect external displays later
    #Option "AllowEmptyInitialConfiguration" "on"
    Option "UseDisplayDevice" "none"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

How can I solve this error?

share|improve this question
    
Did you solve it? I want to buy this laptop and not sure if everything will work. –  umpirsky Apr 13 at 8:08
    
It's working now but I really don't know at what point in time it started working. –  Tom Apr 13 at 19:15
    
Probably some update. Thanks! –  umpirsky Apr 14 at 7:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.