Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Dear Ubuntu friends,

I am a happy owner of a Dell XPS 15 9530 with Ubuntu 13.10 installed on it. Well... happy until yesterday.

Although with some difficulties to install ubuntu on it (Intel smart technology, High DPI not supported...), I solved all the issues and managed to enjoy a lot the world of Ubuntu (with a 1920*1080 resolution).

However 2 days ago I naively accepted an "Ubuntu base" update. Since then I had to postpone my work for struggling on nvidia drivers issues and wrong resolution. Here are all the new problems I encounter:

  • Stuck in High Resolution (3200*1800): in the system preferences, display tab, only this resolution available (built-in display only available). It's particularly bothering because everything is extremely small in size.
  • Brightness control buttons not working. I also been looking a lot on google to solve this.
  • If trying to watch a video, these ones lag a lot (only 4-5 images per seconds). I can also notice this when I switch of workspace or if I write fast...

The followings might help you to understand my problem:

  • No ubuntu loading logo when starting up.
  • Launching nvidia-settings seems to work, but my terminal will also display this error message: first line "(nvidia-settings:7024): WARNING : PRIME: Failed to execute child process "/usr/bin/prime-supported" (No such file or directory)" second line "Message: PRIME: is it supported? no"

While trying to re-install (again and again) the nvidia drivers, I succeed to obtain all the possible errors :) but never to make it work :(

Lastly I have been following this tutorial: http://wiki.belmankraul.com/linux/mint16_bumblebee This is the last configuration I have (nividia drivers 331.38). Not sure if everything worked so I would like to add that: I am not using mint, only ubuntu, but nothing on the tutorial seems to apply only for mint...

I have seen some solutions on similar problems would be to use nvidia-xconfig. I would prefer not because it will create a xorg.conf, which can affect my bumblebee configuration.

It is with a great pleasure I would provide you any command results or file' contents.

Thanks,

Edouard

PS1: I might be verbose... Tell me what is unrelated to my problem and I will edit my question.

PS2: I have seen that version alpha 2 of 14.04 has been released few days ago. Might help? However this is my work station so I would prefer the most stable solution...

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Ok everything back to normal (resolution, brightness control, ubuntu logo loader during start up, video card...)

Here is my guess of what happened:

When I installed saucy, I didn't set up the nvidia optimus card. I had to specify the option "nomodeset" to the grub for being able to boot. However, when I updated my ubuntu base, it seems I didn't need anymore this option. I thought it was a problem of nvidia optimus and therefore installed bumblebee with the latest nvidia drivers (at least now I have it).

I therefore solved my problem by changing my boot options like this:

sudo gedit /etc/default/grub

I changed this line:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=vendor dell_laptop.backlight=0 nomodeset"

to this one:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor dell_laptop.backlight=0"

and updated the grub:

sudo update-grub

I did a reboot and, the resolution was back to normal, the ubuntu logo load during start up was back, and no more lag with videos or desktop effects...

However the brightness control buttons were still not working. This was due to my new drivers. I just had to read this thread in askubuntu: Changing the brightness stopped working in 13.10 saucy salamander , and applied the solution for intel video cards:

Creating the 20-intel.conf file with:

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

And adding the following inside:

Section "Device"
    Identifier  "card0"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
    BusID       "PCI:0:2:0"

EndSection

Reboot and all good :) Brightness buttons are working again :)

I think my problem was very specific, not sure if it will help anyone... In case you have the solution here :)

Cheers!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.