Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can run Oracle's SQL Developer 3.0 by clicking on "sqldeveloper.sh" from the file manager and then clicking "Run". When I add it to the Unity menu (Right-click running icon in menu, click "Keep in Launcher", the new icon doesn't work.

Once I close SQL Developer, I click on the new icon in the Unity bar and it does nothing except flash a few times.

share|improve this question
    
It's a bug, alas: bugs.launchpad.net/unity/+bug/765466 –  elmicha May 10 '11 at 18:18

4 Answers 4

up vote 3 down vote accepted

Right click on the desktop and create a new launcher. Then drag this launcher to the unity bar.

I would recommend to move the launcher to another folder before you drag it to the unity bar because you just create a link to that launcher. If you move the launcher to ~/.local/share/applications/ you are also able to find it by typing the name in the unity search.

share|improve this answer
    
That worked! Thank you. –  Charles Burns May 12 '11 at 16:21

That worked, partially. I do get a launcher entry. However, when I actually run the launcher entry, the running instance of SQL Developer adds an additional icon into the launcher (slightly different image with a green background).

The sqldeveloper.desktop file contents are as follows

[Desktop Entry]
Categories=Development;IDE;Java;
Comment=Oracle SQL Developer
Encoding=UTF-8
Exec=sqldeveloper
Hidden=false
Icon=/usr/share/sqldeveloper/icon.png
Name=Oracle SQL Developer
Terminal=false
Type=Application

The second icon has no "Keep in Launcher" option if I right click on it.

Any suggestions for getting the launcher to associate the running program with the original launcher icon?

share|improve this answer
2  
Welcome to Ask Ubuntu! Please ask this as a new question by clicking the Ask Question button on the top right of the page. –  Jorge Castro Sep 13 '11 at 22:00

I managed to get Oracle SQL Developer to work correctly from dash by adding the following line to my sqldeveloper.desktop file located in ~/.local/share/applications/:

StartupWMClass=oracle-ide-boot-Launcher

This was found by using

xprop WM_CLASS

and clicking on the opened SQL Developer Window.

share|improve this answer

I my case, it was also needed adding the JAVA_HOME environment variable. So the sqldeveloper.sh now looks like:

#!/bin/bash

export JAVA_HOME=/opt/java/jdk1.6.0_34
cd "`dirname $0`"/sqldeveloper/bin && bash sqldeveloper $* > sqldeveloper.log &
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.