Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use a monitor that is exactly 2×1024 pixels wide as a substitute for a dual-screen configuration.

In Ubuntu 10.10, I could open two windows in a row and each would be automatically placed on a different half of the screen, like this:

Idea behavior

In Ubuntu 11.04, the launcher introduces a displacement in the default location for new windows that causes them to encroach upon the other half of the screen. The resulting default behavior is now to create an overlap of the two windows:

Current behavior

This is senseless. How can I restore the normal behavior?

Also, I would like to preempt the suggestion that I simply shorten the default width of windows to accommodate the for the launcher. Firstly, this defeats the purpose of having purchased a monitor this wide in the first place; 1024 pixels is an important minimum width to meet because many popular websites are designed for this size and will display horizontal scroll bars if the windows are smaller:

Current behavior

More importantly, though, is that I frequently use the default Grid plugin in Compiz to move windows from one half of the screen to the other. This action automatically resizes windows to half of the screen width, so my narrower widths would quickly be overridden.

share|improve this question
up vote 1 down vote accepted

Since I don't use Unity, I don't know for sure, but if you set the Unity launcher be always hidden, then maybe your windows won't shift to the right to accommodate it. enter image description here

share|improve this answer
Thanks, this is a great workaround. – ændrük May 12 '11 at 13:24

Unity won't position windows overlapping its Launcher, but you can move them there yourself. Unity also won't let you move the Launcher to the bottom, but you can choose not to use Unity and instead use classic mode . . . or set Unity to Autohide the Launcher. I tried that out (install CompizConfig Settings Manager, then find Ubuntu Unity Plugin under Desktop and set Hide Launcher to Autohide) and when I launched terminal it hid Launcher first and then placed the terminal window against the left edge.

You can also look at the Place Windows plugin under Window Management in CompizConfig Settings Manager. I use that to automatically place my Firefox and Thunderbird windows where I like them. I'm not sure how that would interact with the Grid plugin, but maybe placement of Firefox windows at 0,0 would do what you want. If not, I think you'll need to autohide the Launcher or use classic mode so there's nothing on the sides of your screen.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.