Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Please forgive me if there's any answer out there and I just haven't found it.

I've been reading up on this topic quite a bit (about a week,) google, ubuntu bugs, askubuntu, you name it... have already disabled this driver just so I could get the wifi to work. Took a look and this is the one that comes pre-packaged with this distro (I believe.) Usually I'm pretty steadfast and try to do my homework as 99% of the time others have hit the issue already, and created a workaround or solved it...

My current state -- I've got the wireless working like probably a lot of ubuntu users out there. Though I'm not exactly thrilled with using the open source driver as it doesn't support power management I don't believe, ideally this is something I'd like to take advantage of being very conservative and loving my extended battery life. My battery life in Ubuntu right now is horrid compared to windows (slowly working on that.)

I've got a Dell Latitude E6430, with an extended battery, so every last bit of power savings I can squeeze out of this the better, even if it means resorting to using Broadcom's already proving to be a pain.. driver.

Any insight, help, etc.. is greatly appreciated and if there's anything else I can do to help please let me know. I'm more than willing to dive into this and give any info needed, just let me know.

http://www.broadcom.com/support/802.11/linux_sta.php -- 6.30.223.141

Here's some basic info to start:

some_user@some_host:~$ lspci | grep Wireless 03:00.0 Network controller: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter (rev 01)

some_user@some_host:~$ iwconfig
eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"Some_SSID"
Mode:Managed Frequency:2.412 GHz Access Point: F8:1E:DF:FA:B4:A5
Bit Rate=28.9 Mb/s Tx-Power=19 dBm
Retry long limit:7 RTS thr:off Fragment thr:off Power Management:off Link Quality=52/70 Signal level=-58 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:24 Invalid misc:63 Missed beacon:0

share|improve this question
    
Have you done anything suggested by this post? If you could please add anything that you have tried to your question. askubuntu.com/questions/55868/… –  jmunsch Feb 4 at 5:00
    
What is the result of: sudo iwconfig wlan0 power on ? –  chili555 Feb 4 at 14:15
    
Thank you very much jmunsch! That link we beyond helpful. –  Sum Giais Feb 4 at 17:04
    
Whoops, (hit enter)... The procedure that covers the bcm4313 under "wl - Proprietary Broadcom STA Wireless driver" did it for me. I now see it as eth1 properly, and successfully enabled power management on it. 'code'sudo apt-get install linux-headers-generic sudo apt-get install linux-headers-$(uname -r) sudo apt-get install --reinstall bcmwl-kernel-source'code' –  Sum Giais Feb 4 at 17:07
    
Also doing: sudo iwconfig wlan0 power on Yielded an 'Operation not supported' type error as expected. –  Sum Giais Feb 4 at 17:09
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.