Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just launched new EC2 instances with the Ubuntu precise and saucy AMIs. I installed jfsutils, but I am unable to mount a JFS volume:

$ sudo mount -a
mount: unknown filesystem type 'jfs'

Looking at /proc/filesystems it seems that neither JFS nor XFS are listed (nor BtrFS, for that matter). There doesn't seem to be any module to load:

$ sudo modprobe jfs
FATAL: Module jfs not found.

It looks like the standard 'generic' kernel is installed:

$ uname -a
Linux ip-10-0-0-209 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

What am I missing? Am I just stuck with ext3/4 on this machine?

JFS did work on the 10.04 EC2 AMIs.

share|improve this question
    
What kernel do you have installed? Please provide the output of uname -a in your question. I suspect the EC2 instance runs a specific kernel which is a minimal build, without generic modules included. –  gertvdijk Feb 10 at 13:51

1 Answer 1

seems to be modules were missed install them with xfsprogs

sudo aptitude install xfsprogs
share|improve this answer
    
I get: E: Unable to locate package partman-jfs. I get the same trying to install the jfs-modules dependency directly. I'm using the default sources.list with main and universe enabled. –  Aryeh Leib Taurog Feb 3 at 13:16
1  
The partman-jfs package description says "Warning: This package is intended for the use in building debian-installer images only. Do not install it on a normal Ubuntu system." –  Aryeh Leib Taurog Feb 3 at 13:16
    
Sorry for the delay. Now are you able to mount it manually ? like with ` mount -t xfs /dev/sdaXX /path/to/mountpoint`@AryehLeibTaurog –  AgentCool Feb 11 at 5:57
    
@AryehLeibTaurog Next try to install xfsprogs –  AgentCool Feb 11 at 5:58
2  
Now I can format and mount XFS volumes. But JFS still does not work. –  Aryeh Leib Taurog Feb 11 at 12:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.