Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried going to Region and Language and adding a layout, even making it the default layout, but for some reason I'm stuck with my original layout and I can't seem to change it. In GNOME 2 and in Unity, there's a panel applet that allows you to quickly change between keyboard layouts, but there doesn't seem to be one in Gnome Shell. Does anyone know a way to get that applet in the panel (loading it manually?) or at the very least change the keyboard layout via the terminal?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

You'll find the keyboard layout settings in the region and languages setting panel. Go to the user menu, choose System Settings, then Region and Language, then switch to the Layouts tab.

The layout chooser and keyboard shortcuts (under options) should be pretty familier from the Gnome 2 days. Once there is more than one layout you should get a little switcher applet too.

share|improve this answer

This worked for me... got to:

System Settings --> Keyboard layout, tab Layouts --> Options... Key(s) to change layout

Pick any one you like, even multi options work for me...

share|improve this answer

Don't try. It is technically possible through the "Regions and Languages" section but weirdly enough, when I added another kayboard layout, the themes got messed up. Then I thought a reboot might help and it would NOT LET ME LOG BACK IN. Luckily enough I could log back into unity, remove the keyboard layout and everything was fine again.

This was tested on Ubuntu 11.04 with the Gnome3 repos.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.