Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

im trying to get aircrack working i get this when using the airmon-ng start wlan0 command.

root@ubuntu:/home/bryan# airmon-ng start wlan0


Found 5 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!
-e 

PID Name
797 avahi-daemon
798 avahi-daemon
998 NetworkManager
1033    wpa_supplicant
1291    dhclient

Process with PID 1291 (dhclient) is running on interface wlan0

Interface   Chipset     Driver

wlan0       Atheros     ath9k - [phy0]

ERROR: Neither the sysfs interface links nor the iw command is available.
Please download and install iw from
http://wireless.kernel.org/download/iw/iw-0.9.19.tar.bz2

when trying to install this iw-0.9.19.tar.bz2 apparenly it says is already installed.

so far i have tried installing this compat-wireless-3.5.1-1.tar.bz2 using this steps

 tar jvxf compat-wireless-3.5.1-1.tar.bz2

 cd compat-wireless-3.5.1-1

 scripts/driver-select ath9k

 make

 make install

 reboot

but i keep getting the same message as above. im using asus laptop with AR9285 wireless adapter on ubuntu 12.04

please any help would be really appreciated thanks.

share|improve this question
    
did this card work when you booted the live CD/USB? –  virtualxtc Feb 3 '14 at 4:33
    
hi, well if you mean if the wireless card worked when i installed ubuntu then yes ican browse the internet fine, but i didnt installed ubuntu from CD or USB, i used the autoinstaller on windows 7. –  user228424 Feb 3 '14 at 23:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.