Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu Gnome 13.10 and I can't figure out why I can't make changing keyboard layout shortcut to Ctrl+Shift. I have 3 languages in my input sources. I see in Tweak Tool that "Key(s) to change layout" is set to Ctrl+Shift. If I open dconf Editor I see that in desktop->ibus->general->hotkey the next-engine an next-engine-in-menu preferences are set to ['Alt+Shift_L'].

But somehow I have figured out that input language can be changed by Ctrl+Shift+L. When I click Ctrl+Shift I can see the language changing in the top right corner, but input language stays the same. Any ideas why this can happen and how can I change it?

UPDATE: Also, I have found that changing system keyboard shortcut setting works in System Settings->Keyboard->Shortcuts->Typing->Switch to next(previous) source. But I cannot set there Ctrl+Shift or Alt+Shift setting which I want to set. The only comfortable combination I set there was Ctrl+Shift+Space. I have seen a bug on this here: Bug #1218322: Can't set keyboard layout change to alt+shift, ctrl+shift, etc.

Any suggestions on how it can be fixed?

share|improve this question
    
possible duplicate askubuntu.com/questions/412576/… –  JohnnyEnglish Feb 3 at 21:11
    
not a duplicate, cause that is not the answer. read my question carefully please. –  Yuriy Yunikov Feb 3 at 21:29
    
did you try this one? askubuntu.com/questions/356357/… –  JohnnyEnglish Feb 3 at 21:38
1  
yes, didn't worked for me either. as I said setting 'System Settings->Keyboard->Shortcuts->Typing->Switch to next(previous) source' works, but I can't set there Ctrl+Shift option (just shows 'disabled'), but can Ctrl+Shift+Space. –  Yuriy Yunikov Feb 3 at 21:45
1  
Nothing helps, unfortunately. –  Yuriy Yunikov Feb 4 at 19:59
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.