Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have checked other pages with unmet dependencies and applied the solutions but I still receive the following error:

The following packages have unmet dependencies:
     libminiupnpc-dev : Depends: libminiupnpc8 (= 1.6-3ubuntu1) but 1.6-precise2 is to be installed
    E: Unable to correct problems, you have held broken packages.

Can some one help with this specific unmet dependency?

share|improve this question
Same issue, I filed a bug here > – Brendan Feb 14 '14 at 2:44
did you try sudo apt-get install aptitude && sudo aptitude install libminiupnpc-dev? – Avinash Raj Feb 14 '14 at 3:58
@ Avinash Raj This worked as a work around. It downgraded the package and unmet dependencies were resolved. – Jonathan Rogiest Feb 15 '14 at 15:31
Because of your's i changed the main question,see…. – Avinash Raj Feb 15 '14 at 15:34

Work around that worked is by downgrading:

sudo aptitude install libminiupnpc-dev

=> rejected first option and it automaticly searched for another solution. Accepted the next solution which was to downgrade "libminiupnpc8 [1.6-precise2 (now, precise) -> 1.6-3ubuntu1 (precise)]"

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.