Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Finally I've decided to make ubuntu as my primary development environment. After a clean install on a brand new ssd, I've checked sound, video, keyboard hotkeys (Asus N55SF) and everything seemed to work fine. The only thing that bothered me is a little bit noisy fan of the video card (I guess). And as a result a high temperature of the bottom of the laptop (actually not that high, but much higher than I had with Windows). Need to mention that I did not do any heavy tasks... the fan speed was high right after booting with no programs launched.

After googling around I've stumbled on the Bumblebee. I've installed it and was pretty much satisfied with the fan speed decreased. But then I've noticed that my volume control in desktop status bar disappeared and the keyboard volume hotkeys stopped working too. The All Setting -> Sound shows no output and input devices at all, but the sound is working fine. Can not post an inline screenshot, so here is a link.

Here is the output of the sudo dpkg -l | grep -e alsa -e pulseaudio:

ii  alsa-base                                 1.0.25+dfsg-0ubuntu4                               all          ALSA driver configuration files
ii  alsa-utils                                1.0.27.1-1ubuntu1                             amd64        Utilities for configuring and using ALSA
ii  bluez-alsa:amd64                          4.101-0ubuntu8b1                              amd64        Bluetooth ALSA support
ii  gstreamer0.10-alsa:amd64                  0.10.36-1.1ubuntu1                            amd64        GStreamer plugin for ALSA
ii  gstreamer0.10-pulseaudio:amd64            0.10.31-3+nmu1ubuntu3                         amd64        GStreamer plugin for PulseAudio
ii  gstreamer1.0-alsa:amd64                   1.2.0-1ubuntu1                                amd64        GStreamer plugin for ALSA
ii  gstreamer1.0-pulseaudio:amd64             1.2.0-1ubuntu1                                amd64        GStreamer plugin for PulseAudio
ii  pulseaudio                                1:4.0-0ubuntu6                                amd64        PulseAudio sound server
ii  pulseaudio-module-x11                     1:4.0-0ubuntu6                                amd64        X11 module for PulseAudio sound server
ii  pulseaudio-utils                          1:4.0-0ubuntu6                                amd64        Command line tools for the PulseAudio sound server

I've tried to reinstall alsa and pulseaudio with no luck. And though I can re-install the whole system and be very cautious next time I configure it, I wish not to do that if possible. Can anyone help me to fix these volume issues?

Once again, the sound is working fine, but I can't control it's volume neither via keyboard hotkeys, nor through the volume control on the status bar due to it's absence.

Also, I'm not stating that I've lost sound controls after installing Bumblebee. Maybe that was a result of one of my earlier steps of optimizing the system to work with SSD...

Thanks in advance!

share|improve this question
    
Have you considered using ALSA? It's older, but that only contributes to its stability. –  Dillmo Feb 2 at 14:46
    
Thanks for the reply, @Dillmo. I've tried to use ALSA performing actions described in these posts: - itsfoss.com/fix-sound-ubuntu-1304-quick-tip - howto.blbosti.com/2010/04/… - webupd8.org/2010/03/… But the problem persists. It seems that neither of these methods made any changes to my system... still got the sound but can't control it's volume. –  cyxou Feb 2 at 19:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.