Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I set the wrong keyboard layout while installing ubuntu and now it reverts back to English every time I reboot.

I heard this is normal behaviour, but I want to change the default layout from English the German. I found that I have to edit etc/X11/xorg.conf, BUT that file does not exist on 11.04.

Can someone guide me to the file that initiates this ?

share|improve this question
add comment

3 Answers 3

up vote 3 down vote accepted

You can set the default keyboard layout for GNOME w/ Unity Shell by pressing the Ubuntu logo on the top left of your screen and in the search box typing: keyboard and then selecting the keyboard application and going to the layouts tab.

If you would like to change the default keyboard layout for your console (terminal) you can do so by opening up a terminal and typing: sudo dpkg-reconfigure console-setup.

share|improve this answer
    
I feel pretty retarded, there was a button, apply for whole system >.< –  Lucas Kauffman May 11 '11 at 19:32
add comment

That option to change it globally has disappeared in newer Ubuntu versions. It can be canged in the file /etc/default/keyboard (reboot afterwards).

share|improve this answer
add comment

Just switched from US layout to German (on 12.04);

To configure the keyboard layout for tty1:

dpkg-reconfigure keyboard-configuration

/etc/default/keyboard

XKBMODEL="pc105"
XKBLAYOUT="de"
XKBVARIANT="nodeadkeys"
XKBOPTIONS=""
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.