Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Optimus machine.. I was checking for solutions for a game and someone suggested updating the drivers I picked one of the suggested drivers in the system panel .. rebooted and everything was utterly wrong.. Docky doesn't support 3d anymore.. My game isn't starting at all and when I tried to log in with the unity shell the 3d options were off.. went to nVidia's site and downloaded the right driver.. but it gives me this famous error

ERROR: If you are using a Linux 2.4 kernel, please make sure you either have configured kernel sources matching your kernel or the correct set of kernel headers installed on your system.

If you are using a Linux 2.6 kernel, please make sure you have configured kernel sources matching your kernel installed on your system. If you specified a separate output directory using either the "KBUILD_OUTPUT" or the "O" KBUILD parameter, make sure to specify this directory with the SYSOUT environment variable or with the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the kernel headers) were installed, you may need to specify their location with the SYSSRC environment variable or the equivalent nvidia-installer command line option.

I remember overcoming this ERROR don't remember how.. tried to forget about the drivers and use ironhide, but it didn't really get installed.. then downloaded bumblebee-ui and got some problems with it .. what should I do now??!

I have nVidida GeForce GT 425M and using Ubuntu 12.04

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.