Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It's hard to believe how many postings you can find when searching the internet on Nvidia with Ubuntu problems, yet here goes one more:

I have a NVIDIA GeForce GT 430 video card and a 32bit AMD machine. I'm dual booting Windows 7 with Ubuntu 12.04 LTS. I've tried many different ways of installing both the NVIDIA proprietary and Ubuntu packaged drivers as suggested by many different postings. When things don't work, I get a black screen, or a screen with the default GUI background with no icons.

More often than not, the driver (both NVIDIA and Nouveau?) installation DOES appear to work. What happens is I get a nice hi-res view of the desktop, much better resolution than what I see when using the Live CD. Some apps work perfectly (Dash, Home, Firefox, and all of the Libre apps). Other apps (system settings, appearance, software center etc.), an icon appears in the launcher with a ">" within or next to the icon. When you point to that icon, it wiggles, but that's about it. No error message, and no app appears.

I've spent hours trying to get this to work, and I don't give up easily, and I'm looking for suggestions that will get all functions working. Thanks in advance.

share|improve this question
    
for the black screen problem, have you seen this question and the solutions proposed there? –  Wouter Feb 1 at 19:52
add comment

1 Answer 1

I had a similar problem when I first installed Ubuntu and the Nvidia proprietary drivers. I also got the black screen.

What fixed the black screen issue for me, was to enable "nomodeset" in GRUB bootloader.

  1. When you have the black screen press Ctrl+Alt+F1 to get to TTY1
  2. Log in with your username and password.
  3. Run the following command: sudo nano /etc/default/grub
  4. Find the like where quite splash is and add nomodeset in front of it.
  5. Save the change with CTRL+o I think it is (check to be sure, it's written at the buttom of the screen)
  6. Run sudo update-grub and let it find your installs.
  7. Run sudo reboot to reboot the computer and check if it worked.

`

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.