Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I now have Unity 2D running on my laptop, and the jury is still out as to whether or not I keep it or go back to Gnome.

One thing that is throwing me off is that I don't have the same notification icons in the top panel that I like to have.

One is a CPU monitor. My laptop is a little older, so I keep an eye on the CPU usage to know when one process is done and I can start a new one without slowing things down.

The other is UIM. I switch between Japanese and English input, and the UIM indicator applet in Gnome let me know which input mode I was in.

Right now, only my Dropbox icon has carried over (I upgraded from 10.10).

How do I add/remove indicators in my top panel? Right clicking seems to do nothing.

share|improve this question
    
you don't have them 's cause there's no notification area anymore, well there is but it's hidden. –  Uri Herrera May 9 '11 at 4:13
    
Thanks to everyone who offered solutions, but I've given up. Not because there is anything fundamentally wrong with Unity, but it's just not better than Gnome enough to be worth the learning curve of dealing with issues like this. I've decided to just stick with Gnome unless Unity becomes so unbelievably easy to switch to that I don't have to spend time chasing down issues like this. Again, help much appreciated, but I'm letting this go. –  Dave M G May 10 '11 at 10:06
add comment

2 Answers 2

up vote 3 down vote accepted

There's a new system load indicator. see here: List of Application indicators

share|improve this answer
    
That's nice, but unless I'm misreading it, the link says they can't be used in Unity. –  Dave M G May 9 '11 at 9:52
    
I don't know where you read that? I'm currently using it in unity, btw. –  Christoph May 9 '11 at 9:59
    
I was referring to where it says "there is no way to get these on panel or unity launcher." In any case, it provides no instructions on how to add them to whatever Unity calls the panel that runs along the top edge of the screen. –  Dave M G May 9 '11 at 10:24
    
This refers to the "useful quickinfo" - there's no way to get this info into the unity panel (because you can't rightclick - add applet to panel anymore, like you did in 10.10). this is why those indicators are needed. add them by executing the relevant command, in this case hit alt-F2, enter "indicator-multiload". many indicators are automatically added to the startup applications, for others you have to do it manually. –  Christoph May 9 '11 at 12:02
    
I tried hitting [ALT]+F2 then indicator-multiload, but nothing happened. I tried entering it from the terminal command line, and it said "command not found". I looked for it in Synaptic, and it wasn't listed. Where can I access it? –  Dave M G May 10 '11 at 1:10
show 2 more comments

To enable it open a terminal and type:

       gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"

or use dconf-tools, but you need to isntall it.

After the changes, log out and then back in.

share|improve this answer
    
I tried that code, but nothing has changed. My Dropbox icon is still there, but I can not add/remove or even view any other indicators. –  Dave M G May 9 '11 at 7:33
    
You must relogin –  Extender May 9 '11 at 7:52
    
Yep... re-logged in, and even rebooted. Still no joy though. After I log in again, is there something else I need to do? –  Dave M G May 9 '11 at 8:08
    
have you tried with dconf? –  Uri Herrera May 10 '11 at 3:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.