Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Xubuntu 13.10 and have set inactive windows to be transparent. However, is there a way to prevent one window/program (i.e. tvtime) from becoming transparent.

See this screenshot

share|improve this question

1 Answer 1

You'll need to play a little with compiz to get this. Install compizconfig:

sudo apt-get install compizconfig-settings-manager

Run it:

ccsm

And under the Windows Rules section you'll find this rule: "No ARGB visuals". You need there a way to identify your window, either the title, class, etc:

enter image description here

share|improve this answer
    
That didn't work. I followed your instructions. I entered the following in the "No ARGB visuals" field: (tvtime) & title=tvtime. I did this by using the + button, choosing Window Title, and entering "tvtime". See screenshot (drive.google.com/file/d/0BxrzKpGlppKUZFBNVTBPUnExT28/…). –  mc3mcintyre Feb 1 at 19:43
    
I think it didn't work because tvtime changes the window title each time you change the channel. So, how do I identify the Window ID or the Window Class. Something else that might identify this program only. –  mc3mcintyre Feb 1 at 19:44
    
I also tried using the following: class=tvtime -and- name=TVWindow Neither option worked. –  mc3mcintyre Feb 1 at 19:59
    
I can't help you with that, you'll have to find something that exactly identifies that only window. The command xwininfo may help you a little. –  darent Feb 1 at 20:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.