Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 12.04.2 LTS, using Live CD, on my newly purchased ThinkPad S431 laptop(about one month ago, the newest model without touchscreen). Everything is just nearly perfect and works out-of-the-box. Except some issues when and ONLY when the laptop is on battery power, listed below:

NOTE: ALL ISSUES BELOW EXIST ONLY WHEN THE MACHINE IS ON BATTERY.

  1. All USB devices are not recognized. I can't use anything USB, including mouse and external hard drive. I know it must be some kind of auto-suspension of USB devices in order to save power. How do I disable the auto-suspension though?

  2. The laptop will not shutdown. Even when I chose "shutdown", or type "sudo shutdown -h now" in the terminal, the laptop automatically boots up upon shutdown. I know it's a common issue, and I have searched for solutions myself, yet none worked. So I can only close its lid, locking it, and hopefully save some power. Then the WORST thing happens...

  3. It seems that the laptop in logged out/screen-locked state consumes almost EQUAL power when it's in active use(programming, web surfing, etc.). That's frustrating.

Summarizing, I suspect that all these issues must be caused by some mis-configs or bugs in my system's power control systems(ACPI or something) specific to laptops. Yet being a GNU/Linux newbie, I can't effectively find out solution myself. Hope someone can help me here...

Thank you for any help!

UPDATE 02/01/2014:

The following is the messages of dmesg when unplugging the power right after plugging in.

[ 5595.670547] ehci_hcd 0000:00:1a.0: found PCI INT A -> IRQ 11

[ 5595.670583] ehci_hcd 0000:00:1a.0: sharing IRQ 11 with 0000:00:1c.0

[ 5595.670632] ehci_hcd 0000:00:1a.0: sharing IRQ 11 with 0000:02:00.0

[ 5595.670676] ehci_hcd 0000:00:1a.0: setting latency timer to 64

[ 5595.852071] NMI watchdog: enabled on all CPUs, permanently consumes one hw-PMU counter.

[ 5596.010496] ehci_hcd 0000:00:1d.0: found PCI INT A -> IRQ 11

[ 5596.010610] ehci_hcd 0000:00:1d.0: setting latency timer to 64

[ 5596.110461] xhci_hcd 0000:00:14.0: setting latency timer to 64

[ 5612.201288] xhci_hcd 0000:00:14.0: WARN Event TRB for slot 1 ep 6 with no TDs queued?

[ 5612.201301] xhci_hcd 0000:00:14.0: WARN Event TRB for slot 1 ep 0 with no TDs queued?

After I plugged in a USB Device(my hard drive), however, there were NO dmesg updates.

share|improve this question
    
Please post the messages of dmesg after unplugging power. Also post after connecting a usb device, on battery. –  davidbaumann Feb 1 at 4:44
    
Sorry about replying so late... Will update the post right away. –  user2490821 Feb 2 at 3:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.