Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When attempting the Ubuntu HTML5 tutorial on the Ubuntu site, I have just created the template app and am attempting to run it. When I run it, I get this error:

Starting ubuntu-html5-app-launcher --www=/home/shah/Code/qrcode-scanner

/usr/bin/ubuntu-html5-app-launcher: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory ubuntu-html5-app-launcher exited with code 127

I am not sure how to resolve this and I cannot find any threads with fixes regarding this problem. I have tried a sudo apt-cache search libQt5Core which indicates libqt5core5 but I already have that installed, so I'm wondering if something else is wrong.

share|improve this question
    
@DavidPlanella ? Shah, do you have the /usr/lib/i386-linux-gnu/libQt5Core.so.5 file? –  Wilf Jan 31 at 21:16
    
@wilf - That file isn't there, I did a locate and found it here: /usr/lib/x86_64-linux-gnu/. I'm using 64 bit Ubuntu. –  Mendhak Jan 31 at 21:23
    
Oh sorry, mine was for 32bit, not 64bit - though if the Qt Creator is 32bit version... you could try sudo cp /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 /usr/lib/i386-linux-gnu/libQt5Core.so.5 - as this a library file, it should not cause any damage if it is also elsewhere (hopefully) –  Wilf Jan 31 at 23:08

1 Answer 1

It should be fixed now, it was a packaging issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.