Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have xubuntu 13.10 installed on a late 2013 macbook pro. It has a broadcom wireless card:

lspci -vvnn | grep 14e4
02:00.0 Multimedia controller [0480]: Broadcom Corporation Device [14e4:1570]
    Subsystem: Broadcom Corporation Device [14e4:1570]
03:00.0 Network controller [0280]: Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)

I'm running the latest broadcom driver from Ubuntu:

rsyring@LofTEX:~$ dpkg -l | grep -i broadcom
ii  bcmwl-kernel-source                                         6.30.223.141+bdcom-0ubuntu1                   amd64        Broadcom 802.11 Linux STA wireless driver source

But, I'm having wireless internet problems. Running ping, I'm showing significant packet loss, up to 100%, and also sometimes showing "errors" in the ping statistics.

I've seen this same behavior on two different wireless networks. The wireless works fine when running OSX.

Suggestions?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Turns out this has to do with power management. I came across this note in the ArchWiki:

https://wiki.archlinux.org/index.php/broadcom_wireless#Miscellaneous_user_notes

If you notice slow wireless speeds when your laptop/netbook is not connected to AC power, you may need to disable Wi-Fi power management by adding the following line (assuming wlan0 is your wireless device) iwconfig wlan0 power off to /etc/rc.local and create an empty file /etc/pm/power.d/wireless. In case you also experience interface swapping (discussed above), you might want to add another line for the second interface name as well. The command will have no effect on the wired interface. --Tom.yan, 16 August 2011

And I did notice the wireless problems only came when I was running on battery. I ran:

sudo iwconfig eth0 power off

and my problems stopped instantly.

share|improve this answer
    
What does the empty file in /etc/pm/power.d/wireless do? –  Randy Syring Feb 10 at 3:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.