Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm attempting to mount a WD Elements 1 TB drive on Linux, however it does not work. The drive is only visible through gparted. When I reformat the drive while on Linux, partitions work no matter what - fat, ntfs, ext it all mounts fine.

However, after one reboot it's impossible to mount it. This happens on all my Linux installs, while the drive works on all Windows installations I tried it with.

I'm using 64-bit Ubuntu 13.10.

EDIT: Unmounting/unpowering before unplugging the device is what I was doing, and the drive still always appears the same after a reboot - in the "Disks" application, without any partitions (although gparted sees them).

share|improve this question
    
@user68186 I added the information. Unmounting before unplugging does not make a difference. –  user242206 Jan 31 at 18:19
add comment

1 Answer 1

This is a well known defect with WD Elements drives. They ship them with a corrupt format since it claims the disk is slightly larger than it actually appears to be. You will need to repartition the drive to correct WD's error, and you should complain loudly to WD so maybe they will stop shipping broken drives.

share|improve this answer
    
Thanks, but as mentioned, it does not work even after reformatting. I tried formatting the drive as half ntfs half ext2 (ideal setup I was trying), I tried to make a new mbr and such, but in the end the drive was still not recognized after a reboot. –  user242206 Feb 1 at 21:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.