Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

UPDATE 1:

The problem is not a monitor refresh rate flickering problem, as then the whole screen would be flickering. For me, only the application windows flicker in and out of view, then most of the time, when there do decide to show themselves, they only partly show themselves, like just top half, bottom half, left half, corner missing, window disappears when you try moving it or mouse over it even etc etc.

I know it is a visual effect problem as I know my computer cannot handle visual effects and for some reason when the windows do appear partly, I can see the shadows behind the windows. Those shadows are part of the visual effects which are turned on by default for some reason.

I get the same problem with 10.04, but can quickly turn off the visual effects by right clicking the desktop, selecting change background image, and in the visual effects tab, I can click on none, which stops all the visual problems.

ORIGINAL QUESTION:

I am having problems with 11.04 on my computer. For some reason it is enabling visual effects by default in the live cd when it should not be as my computer cannot support such effects. My computer cannot support Unity either, but it defaults to standard gnome with visual effects for some reason. It should be defaulting to standard gnome with no visual effects. THerefore, all I get is a very flickery live cd which makes it very difficult to see anything.

So my question is, how do I disable the visual effects from the live cd?

To put it simply, the live cd flickering is so bad, that I had to log back into my standard 10.04 install just to write this question, as I just couldn't see enough of the screen because of the flickering in 11.04 to even get to askubuntu.com...

share|improve this question
    
Please see update 1 in the original question for further details. –  oshirowanen May 9 '11 at 12:05

4 Answers 4

up vote 3 down vote accepted

Try pressing F4 on the main boot menu screen and selecting "safe graphics mode" as detailed here, although I think this may no longer be offered in 11.04 as it is not included here. Are you sure this is a Compiz-related problem, as Compiz will typically not be activated if it cannot be supported by the hardware.

share|improve this answer
    
Visual effects are definitely enabled, as I can just about see the shadows behind the windows. When visual effects are disabled, the windows do not have shadow effects. –  oshirowanen May 9 '11 at 8:31
    
Have you confirmed with a different installation/version that everything looks fine when visual effects are disabled? Are you sure that it is visual effects, and only visual effects, that are causing the problem? Screen flickering is often related to an incorrect refresh rate. Is the screen a CRT or LCD type? –  SabreWolfy May 9 '11 at 8:46
    
Yes, I have tried downloading the cd twice and get the same issue. When I turn visual effects on in 10.04 it goes crazy, just as it is going crazy with the live cd of 11.04. As soon as I turn off visual effects on 10.04, all it back to normal. I cannot figure out how to turn off visual effects in 11.04. It is not a refresh rate problem. It is a different type of flickering e.g. where the menu bar disappears and the windows disappear and reappear only partly, but the background always remains as is. So I am sure that the problem will be solved as soon as the visual effects are turned off. –  oshirowanen May 9 '11 at 10:36
    
Just don't know how to turn off the visual effects by default, i.e. some how boot into the live cd with visual effects forced off. –  oshirowanen May 9 '11 at 10:36
    
Please see update 1 in the original question for further details. –  oshirowanen May 9 '11 at 12:04

If you can start 11.04 you could try following:

  1. Start terminal by pressing super-key and then type "terminal" (without quotes) and hit enter.
  2. Wait a few seconds, then type: "metacity --replace &" and hit enter.
  3. If this works you can quit the terminal by typing "exit" and enter.

If that worked you can create a autostart entry in system settings with the command "metacity --replace".

share|improve this answer
    
I will try this tonight. Is there not a more permanent way to get it to default to metacity? Instead of placing that command in the autostart section? –  oshirowanen May 12 '11 at 9:03
    
If you want these changes permanently then you will have to run off a Live USB with permanent storage or off a proper install, not off a Live CD as per your original question. Once you have disabled visual effects, however, they should remain off. –  SabreWolfy May 12 '11 at 10:20

just go to your appearances tool and turn off visual effects. worked for me. Then, when you are ready to re-enable go back to the appearances box and turn on effects. compiz will begin working again.

share|improve this answer

A post here suggests pressing F6 and adding i915.modeset=0 xforcevesa to the end of the line.

share|improve this answer
    
Thanks, I'll give this a try also tonight if the F4 graphics safe mode does not work. –  oshirowanen May 9 '11 at 14:09
    
That doesn't seem to make any more difference than pressing F6 and selecting nomodeset. –  oshirowanen May 12 '11 at 9:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.