Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu for the first time dual boot so I get to choose Ubuntu or windows. I then changed the setting where is doesn't ask for my password when booting up. I then installed Edubuntu desktop package. I then hit system and logged out that way i could be at the loggin screen that also lets you select the desktop environment. Edubuntu was not there but User defined session was so i clicked that thinking that might be Edubuntu and logged in. Now im totally stuck. Only walpaper on the screen as i realize now that is normal for user defined session but there is no log out button to change desktop environments now and since I set it to not ask for password at boot up there is no option to change it at start up. If i hit ctrl+alt+del it only lets you shutdown, restart, suspend, or hybernate.... no logg out. I have hit every key on the keybourd hoping something will pop up. I thought this must be a simple noob mistake that there must be endless artiles about this so did searches on google and forums and was shocked to find nothing about this. My next step unless someone can help is to uninstall and reinstall.

share|improve this question

5 Answers 5

Very similar thing happened to me, I am also new to Ubuntu (11.04) and was just experimenting and poking around and got stuck in User-Defined mode. Not knowing anything about Linux at all really, it's almost impossible to get out of there by just guessing.

Try this, it worked for me:

  1. Right Click anywhere on the desktop.

  2. Click "Create Launcher". The Create Launcher window should pop up.

  3. In the Create Laucher Window, put "Login" for NAME (or whatever you want, it's not important) and put "gdmsetup" for COMMAND. Click OK.

  4. You should have an icon on your desktop now called Login, or whatever you called it. Click that.

  5. The "Login Screen Settings" window should open. You will have to click unlock and enter your password.

  6. Now make sure the "Show the Screen for Choosing Who Will Login" button is selected. Close this window.

  7. Use CTRL + ALT + DELETE to restart your computer.

  8. The login screen should now appear instead of taking you directly into the user-defined session. Select the Ubuntu Classic (or whichever session you want) on one of the bottom tabs.

Hope that helps!

share|improve this answer

Right-click on the desktop. Choose Change Desktop Background. Select All Settings tab. Then, double-click User Accounts. Unlock the administrator's account and turn off Automatic Login, then lock it again. Done!

I realize this post may somewhat late, but this little desktop recovery tip may be good for all Ubuntu versions since Unity, I think. I am using 12.04 alpha and it did work for me. I am pretty sure it works for 11.04 and 11.10.

share|improve this answer

I'm using ubuntu 11.10 and I replicated what you had in user defined screen. All I did CTRL-ALT-DEL and a logout screen came one and I logged out successfully.

share|improve this answer

You can go at "keyboard preferences" , then Options (bottom left) , then "key sequence to kill the x server" and set check that.

After that , when you press control-alt-backspace it will force a log-out.

From there you can choose to login wherever you want.

(that is, of course, if you can get the menus somehow. alt-f1 bring the classic gnome menus - i'll go find the command that opens keyboard prefences in case alt-f2 works on your system too. edit : that would be "gnome-keyboard-properties")

share|improve this answer
    
alt f1 does nothing same as alt f2, crtl+alt+backspace does nothing either –  Dan May 8 '11 at 21:25

Adding in the Launcher with "gdmsetup" in the command works, but in my case, I had to turn off automatic login because it didn't allow me to ONLY change the session. I had to go back to selecting the user and change the session there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.