Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It's not a question but I think it can be useful ...

While dist-upgrading a saucy custom DVD, I've got an error about whoopsie:

invoke-rc.d: unknown initscript, /etc/init.d/whoopsie not found.
dpkg: error processing /var/cache/apt/archives/whoopsie_0.2.24.1ubuntu1_i386.deb (--unpack):
 subprocess new pre-removal script returned error exit status 100
invoke-rc.d: unknown initscript, /etc/init.d/whoopsie not found.
...
Errors were encountered while processing:
 /var/cache/apt/archives/whoopsie_0.2.24.1ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Investigating a little, I've found that on my other pc, running precise, /etc/init.d/whoopsie, was a symlink:

whoopsie -> /lib/init/upstart-job*

while in chrooted saucy looking for /etc/init.d/whoopsie I've got cannot access /etc/init.d/whoopsie: No such file or directory

So I've created the above symlink and finally dist-upgrade worked fine.

Silvia

share|improve this question

1 Answer 1

I'm running Ubuntu 13.10 (i.e. Saucy) and have Whoopsie installed but don't have /etc/init.d/whoopsie OR /lib/init/upstart-job.

I'm also trying to create a custom Ubuntu 13.10 LiveCD and can confirm the above fix works when I run it in the chroot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.