Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm a student and I have access to a pretty powerful machine in the University lab. I've been trying to allow my roommates to remotely login to my machine on an account that I've created so that they can run some computationally intensive tasks. The idea is that their work will not interfere with mine while I'm working physically on the machine.

Towards this, I modified /etc/lightdm/lightdm.conf to contain

[SeatDefaults]
user-session=ubuntu
greeter-session=unity-greeter
autologin-user=

[XDMCPServer]
enabled=true
port=177
#key=

[VNCServer]
enabled=true
port=5900
width=1920
height=1080
depth=16

and this automatically opens 5900 and grants a new login screen to each vnc session.

However, upon logging in, all I get is an unusable desktop. Keyboard commands like ctrl+alt+t don't seem to work. I'm able to use the mouse however, but I don't get the unity launcher. When I right-click and goto Change Desktop Background, I notice that the window seems to lack the maximize, minimize, close icons as well.

I'm not an expert at Linux and am thus at a loss to better explain my predicament.

Any help would be greatly appreciated.

edit: I modified greeter-session=lightdm-gtk-greeter and used GNOME option instead of Ubuntu and was able to achieve the desired results. However, I've gotten really comfortable with Unity and would like to know if it is possible to achieve the same with Unity..

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.