Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a dual monitor setup going. I want to play a video (using SMplayer) on the second screen while using applications on the first screen. I have it working except for one annoying thing. When ever I switch focus from SMplayer to a different application on the other screen the Unity panel shows up above the video.

Is there anyway I can stop the panel from showing up when I switch focus to a different application?

share|improve this question

4 Answers 4

You could try upgrading to 12.04, there have been many improvements to the way dual screens are handled, and you can control better how the launcher works with dual screen (on System Settings > Displays, and System Settings > Appearance > Behaviour). If it still doesn't work for you can you add more detail to the question please? I am not sure exactly what you are seeing. But try it in 12.04 first.

share|improve this answer

Unfortunately there doesn't appear to be a way to stop this from happening. I've spent hours searching for a solution.

I run into the same issue using vmware workstation on a second screen in full screen mode. In the end I had to install gnome 3 as this has the option to disable the panel on the second screen. I believe there is a feature request to remove the panel on the second screen in Unity.

share|improve this answer
1  
Do you have a link to the feature request? –  Eliah Kagan Jul 10 '12 at 15:59
    
I think this was the link although it looks like the feature request has been closed off. I've been using gnome3 instead of Unity for the past couple of months for the same reason. –  Jagged Jul 11 '12 at 3:06
    
I've created a new feature request for this item: brainstorm.ubuntu.com/idea/30152 –  Jagged Sep 18 '12 at 0:44

I also use a dual-monitor setup and have had the same issue.

You can fix it by setting the video to "Always On Top" while it is playing. If you're using Gnome Classic, as I am, just right click on it's panel entry and select the keep on top option. Then the panel won't appear over your video.

share|improve this answer

I believe, using ccsm if you use the workarounds plugin and enable "legacy full screen support", you may get the desired result.

You can also use a tool like ubuntu tweak to stop unity from monitoring the second monitor, though this is probably not advisable.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.