Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was wondering, I like the fullscreen mode (host + f by default), but this is unfortunately not very helpful with a 3200x1800 resolution screen (15 inches). The scaling mode (host + C) is better, but not quite the same. what I want is something like fullscreen scaling, where you can set a maximum resolution, beyond that it scales to fit the screen. (at least I think I want something like this.)

If I had to pick a static resolution then that's ok too. (say i'd like to pick 1920x1080 for my 3200x1800 display), and then have this resolution stretched / scaled to fullscreen coverage. But how would I go about this?

I hear there's the same kind of issue for others with retina displays where the dpi is so high that all of Ubuntu's icons / buttons and UI in general becomes too small for comfort. I feel that until Ubuntu officially supports high DPI screens, then scaling it from a virtualbox image must be achievable right?

Last point... this might be an issue with the vbox additions driver auto adjusting the size of the ubuntu window to match that of the host...

I've tried Oracle VM VirtualBox Manager -> File -> Preferences -> Display -> Maximum Guest Screen Size. Which seemed like it was exactly what I wanted, but it did not do anything.

TL;DR: High DPI screen on host, ubuntu guest tries to match this = tiny UI & icons.

Any help would be much appreciated! (the end result is to just want to use ubuntu on a high DPI screen, the path taken does not matter as much. However it seems like I would have most success through virtualbox here)

share|improve this question
What DE do you use? Most of them allow to change font size, icon size or even have settings for scaling everything (ie Gnome3). – cylgalad Jul 1 '15 at 8:07

Ok, so my temporary solution (until Ubuntu supports high DPI i guess...) was to just go down in resolution on my host system (windows), to half the max resolution (1920x1080).

I don't really want to mark this as solved, since it kinda bypasses the problem in an undesirable manner. (this is just what I'm content with doing.)

share|improve this answer
This is exactly what I am doing. Would scaling mode not work if you set guest resolution to be 1/2 of host resolution? Here the guest OS gets completely unusable by this... – Tarnschaf Mar 3 '14 at 19:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.