Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm installing an old laptop for a mentally challenged person who only uses it to listen to music and surf online. A Packard Bell easynote S5.

I've installed Lubuntu 13.10 and everything works perfectly after a little bit of work. The only problem I haven't been able to surmount was that there is no sound.

I first tried to open alsamixer and it game the following output

Cannot open mixer: File or directory does not exist

Neither could I run:

cat /proc/asound/card0/codec* | grep Codec

cat /proc/asound/cards outputs

--- no soundcards ---

sudo lspci -v outputs the following:

00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
    Subsystem: Packard Bell B.V. Device c011
    Flags: fast devsel, IRQ 5
    Memory at b0000000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 2
    Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    Capabilities: [100] Virtual Channel
    Capabilities: [130] Root Complex Link

I tried installing the realtek drivers but those failed

Does anyone have a solution?

Edit: I got a weird suggestion to try editing /etc/modprobe.d/alsa-base.conf I now get a sound icon but still no sound (duh, still no sound card detected)

Oke, I've discovered that the installation process didn't properly install the sound modules since it apparently doesn't have access to the linux-restricted-modules I'm attempting to fix this now

Edit2: Didn't work :(

It might be usefull to note that the sound did work on the (old) version of opensuse that I installed about 7 years ago on this laptop

Edit3: You know what. screw alsa. I'll just use magic and make drivers appear

I found the correct drivers for my sound card (from opensound.com's oos package). It was discontinued in 2008 and doesn't work with my (much newer) kernel :(

The good thing is: I'm getting close

My only options are to either use a really old kernel version or install Windows XP or something like that.

share|improve this question
    
What do you get when you aplay -l – Mr.Lee Jan 31 '14 at 0:04
    
aplay: device_list:268: No soundcards found. – Arno van der Weijden Jan 31 '14 at 0:20
    
Hi, I am have had a similar problem on a totally different architecture. The issue is most likely the kernel modules that are being loaded, or blacklisted. You can remove the /etc/modules (really, you should just rename it... i.e. sudo mv /etc/modules /etc/modules.old) and let udev try to figure out what modules are needed. You can also rename your /etc/modprobe.d/blacklist.local.conf to something else, or comment out the lines related to snd and reboot. You may have to do some serious duckduckgo searching to find the right module for your card. – I-Jo May 10 '14 at 14:00
    
Hi, thanks for helping but I installed windows XP on her computer with some modifications so she can use it. I can't quite get it back now to test your solutions. thanks anyway. – Arno van der Weijden May 10 '14 at 18:42
up vote 0 down vote accepted

I am running ubuntu 14.04 on a msi z170a motherboard. This my fourth ubuntu 14.04 and all my hardware is different. I also run fvwm2 as my window manager so I don't use the gnome or unity desktops. What that means is I run gnome-'setup-stuff' from an xterm or gnome-terminal.

I have spent hours and hours trying to get my sound to work. What has been and worked for my latest build is something like this.

From a terminal logged in as root. or you can sudo commands I believe the following solved my problem.

As root I ran gnome-control-center sound
Then I did

xen2:~> ls -l /dev/snd
total 0
drwxrwxrwx  2 root root       80 Mar 21 11:13 by-path
crw-rw-rw-+ 1 root audio 116,  2 Mar 21 11:13 controlC0
crw-rw-rw-+ 1 root audio 116,  7 Mar 21 11:13 controlC1
crw-rw-rw-+ 1 root audio 116,  6 Mar 21 11:13 hwC0D0
crw-rw-rw-+ 1 root audio 116, 10 Mar 21 11:13 hwC1D0
crw-rw-rw-+ 1 root audio 116,  4 Mar 21 17:16 pcmC0D0c
crw-rw-rw-+ 1 root audio 116,  3 Mar 21 17:24 pcmC0D0p
crw-rw-rw-+ 1 root audio 116,  5 Mar 21 11:13 pcmC0D2c
crw-rw-rw-+ 1 root audio 116,  8 Mar 21 17:04 pcmC1D3p
crw-rw-rw-+ 1 root audio 116,  9 Mar 21 16:54 pcmC1D7p
crw-rw-rw-+ 1 root audio 116,  1 Mar 21 11:13 seq
crw-rw-rw-+ 1 root audio 116, 33 Mar 21 11:13 timer

The ls -l was just to see the files and permissions

The permission for the files above were different when I first looked at /dev/snd. To get a list of file and dirs

find /dev/snd
/dev/snd
/dev/snd/hwC1D0
/dev/snd/pcmC1D7p
/dev/snd/pcmC1D3p
/dev/snd/controlC1
/dev/snd/by-path
/dev/snd/by-path/pci-0000:01:00.1
/dev/snd/by-path/pci-0000:00:1f.3
/dev/snd/hwC0D0
/dev/snd/pcmC0D2c
/dev/snd/pcmC0D0c
/dev/snd/pcmC0D0p
/dev/snd/controlC0
/dev/snd/seq
/dev/snd/timer

Write the above to a file.
xen2:~> ls -l /dev/snd >> /root/reboot_fixes

Then I edited /root/reboot_fixes with chmod 777 for all directoies and chmod 666 for all files.

ever time I reboot I have to run /root/reboot_fixes. but this is the only way I could get sound to work. I've read dozens of do this and none worked. This works for me.

share|improve this answer
    
I'll keep this in mind if I ever have to work with an ancient sound card again but I can't test this anymore. this question is more that 2 years old. I'll accept it so someone else who finds this question can use itl. – Arno van der Weijden Mar 22 at 11:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.