Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm installing an old laptop for a mentally challenged person who only uses it to listen to music and surf online. A Packard Bell easynote S5.

I've installed Lubuntu 13.10 and everything works perfectly after a little bit of work. The only problem I haven't been able to surmount was that there is no sound.

I first tried to open alsamixer and it game the following output

Cannot open mixer: File or directory does not exist

Neither could I run:

cat /proc/asound/card0/codec* | grep Codec

cat /proc/asound/cards outputs

--- no soundcards ---

sudo lspci -v outputs the following:

00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
    Subsystem: Packard Bell B.V. Device c011
    Flags: fast devsel, IRQ 5
    Memory at b0000000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 2
    Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    Capabilities: [100] Virtual Channel
    Capabilities: [130] Root Complex Link

I tried installing the realtek drivers but those failed

Does anyone have a solution?

Edit: I got a weird suggestion to try editing /etc/modprobe.d/alsa-base.conf I now get a sound icon but still no sound (duh, still no sound card detected)

Oke, I've discovered that the installation process didn't properly install the sound modules since it apparently doesn't have access to the linux-restricted-modules I'm attempting to fix this now

Edit2: Didn't work :(

It might be usefull to note that the sound did work on the (old) version of opensuse that I installed about 7 years ago on this laptop

Edit3: You know what. screw alsa. I'll just use magic and make drivers appear

I found the correct drivers for my sound card (from opensound.com's oos package). It was discontinued in 2008 and doesn't work with my (much newer) kernel :(

The good thing is: I'm getting close

My only options are to either use a really old kernel version or install Windows XP or something like that.

share|improve this question
    
What do you get when you aplay -l –  Mr.Lee Jan 31 at 0:04
    
aplay: device_list:268: No soundcards found. –  Arno van der Weijden Jan 31 at 0:20
    
Hi, I am have had a similar problem on a totally different architecture. The issue is most likely the kernel modules that are being loaded, or blacklisted. You can remove the /etc/modules (really, you should just rename it... i.e. sudo mv /etc/modules /etc/modules.old) and let udev try to figure out what modules are needed. You can also rename your /etc/modprobe.d/blacklist.local.conf to something else, or comment out the lines related to snd and reboot. You may have to do some serious duckduckgo searching to find the right module for your card. –  I-Jo May 10 at 14:00
    
Hi, thanks for helping but I installed windows XP on her computer with some modifications so she can use it. I can't quite get it back now to test your solutions. thanks anyway. –  Arno van der Weijden May 10 at 18:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.