Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have one monitor above another. I would like to have a panel at the top of the bottom monitor and another at the bottom of the top monitor.

Putting the panels in place works as expected. However, when the panels are on the edge of a screen that butts up against another screen, space is not reserved for the panel when maximizing windows. So, if I try and maximize Firefox, I can't see the "addons" bar at the bottom.

I have tested this in both kubuntu and xubuntu with similar results. I found a bug for KDE that describes the problem and a comment says:

panels in between monitors are not supported, and this is a limitation in the freedesktop specification for reserving space for things like panels.

There is another forum posts that talks some about this:

Is there any way to get the limitation in the specification addressed and/or are there any workarounds to make the applications maximize without being behind the panels?

share|improve this question

how about this:

Settings Manager -> Panel -> Display -> Uncheck "Don't reserve space on borders"

share|improve this answer
this is the correct answer, helped me :) – Aurigae Jun 3 at 22:23

Easy fix in Xubuntu 12.04 (you didn't say which edition you're using):

Right-click on the panel, select Properties (make sure it's panel properties rather than one of the launchers or applets on the panel_), then click the Appearance tab. Opacity should be set to 100.

If panels are set to "vanish" when not mousing over them, then open windows will go right over the "invisible" panel. Use the settings screen to keep the panel visible.

share|improve this answer
Thanks for the input, but I don't think you fully grasp the problem. – Randy Syring Jan 31 '14 at 18:01

In ubuntu, you can reserve space for your panels with xprop, using the _NET_WM_STRUT_PARTIAL property (the reserved space is called strut). The idea is to get the ID of your panel window with xwininfo, and feed it together with the desired coordinates into xprop -set. If this answer seems to work for you, you can check out my blogpost for a detailed how-to and more info on using xprop.

share|improve this answer

I was having this problem as well. I have the panel at the bottom of the screen. The workaround of making the panel transparent on mouse-exit worked alright, but I noticed that when I moved the mouse all the way to the bottom of the screen, the panel would go transparent as if there was a single pixel between the panel and the bottom of the screen.

I dragged the panel up a little and then back down. After it snapped to the edge of the screen, there was no longer a pixel between it and the bottom of the screen and maximized windows now correctly maximize to the edge of the panel instead of to the edge of the screen.

share|improve this answer

A workaround: go to Panel Settings, make the panel smaller (by dragging it) and maximize it again (there is a "maximize panel" button). After that, windows do not go beneath it anymore.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.