Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cannot upgrade my ubuntu from 13.04 to 13.10

This is error while i try to upgrade:

W: GPG error: http://download.opensuse.org  Release: The following signatures were invalid: KEYEXPIRED 1386276565
W: Failed to fetch http://th.archive.ubuntu.com/ubuntu/dists/natty-backports/main/source/Sources  404  Not Found

W: Failed to fetch http://th.archive.ubuntu.com/ubuntu/dists/natty-backports/restricted/source/Sources  404  Not Found

W: Failed to fetch http://th.archive.ubuntu.com/ubuntu/dists/natty-backports/universe/source/Sources  404  Not Found

W: Failed to fetch http://th.archive.ubuntu.com/ubuntu/dists/natty-backports/multiverse/source/Sources  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

What have i tried already?

  1. Unchecked something like ..from CD-ROM.. on Ubuntu Software Center > Software Source.
  2. Tried to use this command "sudo rm -rf /var/lib/apt/lists/*"
  3. Tried to change download server

How can i solve this problem?

share|improve this question
    
possible duplicate of How to install software or upgrade from old unsupported release? –  karel Jan 31 at 2:36

1 Answer 1

up vote 1 down vote accepted

At some point you added an apt source for that natty-backports repository you see mentioned in your error. This repository is no longer available for some reason.

Find this; it will be either a line in /etc/apt/sources.list or a file in /etc/apt/sources.list.d. Then delete the line or the file, save, and try again.

share|improve this answer
    
"Some reason" being that natty reached end of life over two years ago. –  psusi Jan 30 at 19:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.