Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have often done this before: install ubuntu on a usb and use it to boot from it from different machines (two similar dell laptops, similar components etc.). I know, normally you use a live system for full portability and that the ubuntu installer configures hardware etc. when installing on a specific setup, but I have never had problems with it. (I even ran it successfully on completely different hardware without problems).

Today it thought, I want to try it on a colleagues machine, because he thinks it is kind of broken (windows randomly shows blue screen when working with it). It is a new machine however. So I used a usb that has never been attached to any system but mine before, everything ran fine. Then after I booted the usb on the lattop of my colleague and everything ran fine, I booted it again on my computer: result: does not boot anymore. I thought: okay maybe a file system error, ran btrfsck, but it did not show anything of interest. I ended up setting up the usb from scratch.

After that I set up another usb with a fresh copy of ubuntu. I successfully installed some software, powered the system off and bootet from the colleagues machine. Everything worked. Then I tried to install some software there, but apt complained, that debconf is missing. apt-get install -f did not work either, so basically the whole package management was broken in a irreparable state.

This cannot be coincidence, can it?

So my question is: Could faulty hardware (other than the storage device itself) screw with the root filesystem so that it breaks?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Could faulty hardware (other than the storage device itself) screw with the root filesystem so that it breaks?

Yes.

As an example: Malfunctioning RAM can result in file corruption. editing your /etc/fstab to mount R/O (read only) should reduce the odds of such an occurrence to near zero.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.