Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Disk Information:

I have 10 partitions on my disk currently. Here is the gparted image of my disk.

PARTITION--FILE SYSTEM--MOUNT POINT--LABEL--SIZE--USED--UNUSED--FLAGS

1. /dev/sda1--fat32--/boot/efi--ESP--500 MiB--62.39 MiB--437.71 MiB--boot

2. /dev/sda2--fat32--         --DIAGS--40 MiB--4 MiB--36 MiB--hidden

3. /dev/sda3--unknown--       --     --128 MiB--    --      --msftres

4. /dev/sda4--ntfs--          --WINRETOOLS--500 MiB--269.49 MiB--230.51 MiB--hidden,diag

5. /dev/sda5--ntfs--          --OS--442 GiB--87.30 GiB--354.76 GiB--boot

6. /dev/sda6--ext4--/--           --19.53 GiB--8.71 GiB--10.82 GiB--msftdata

7. /dev/sda7--ntfs--/media/anushree/9CFC5884FC585A9A--350 MiB--304.82 MiB--45.18 MiB--hidden, diag

8. /dev/sda8--ntfs--/media/anushree/New Volume1--New Volume--229.42 GiB--222.82 GiB--6.6 GiB--msftdata

9. /dev/sda9--ntfs--/media/anushree/New Volume--New Volume--229.42 GiB--128.75 GiB--100.67 GiB--msftdata

10. unallocated--unallocated--  --  --1 MiB

11. /dev/sda10--ntfs--         --PBR Image--9.61 GiB--9.32 GiB--289.64 MiB--hidden,diag

12. unallocated--unallocated--  --   --1 MiB

(sorry for the bad readability, but I am a new user and I can't upload images just yet.)

I installed Ubuntu 13.10 on Dell Inspiron 3521 machine by making a 20 GB partition from my C drive.

The OS installed successfuly but on rebooting, it booted directly to Windows 8. After looking through a number of forums for a solution to my problem, I ran boot repair using a live-USB. As a result of that, I got an error: File: \EFI\Microsoft\Boot\BCD missing. Error Code : 0xc000000f. I tried running boot repair a couple more times.

GRUB is installed successfully and Ubuntu is running just fine. But every time I try to boot to windows, it gives me the same error. The GRUB menu has options:

  1. Windows UEFI bkpbootmgfw.efi

  2. Windows Boot UEFI loader

  3. EFI/Dell/Boot/bootmgfw.efi

  4. EFI/Dell/Boot/bootx64.efi

to boot into windows. And none of them are allowing me to do that. The 4th option is the recommended one on every forum. What it actually does is it opens a system recovery screen, the one that open for windows 8, which has the following options:

  1. Refresh

  2. Reset

  3. Advanced Options

The refresh is not working because apparently my c drive is locked and it cannot access it. I do not want to reset my PC because that means I will loose all the data. In the advanced options, the system restore is not working because there is no system image on my PC and I have no backup CD made beforehand (which is I think my biggest mistake). I am looking for any way by which I could save my data. Even the Dell Backup and Recovery option could not find any restore point.

In the command prompt, I have tried to rebuild the BCD using bootrec commands and bcdedit to access the bcd store to relocate the bcd file. But it gives me errors that there are "multiple indistinguishable locations" on the disk and that there was a "failure to copy boot files". No commands are working whatsoever and I cannot find any way to get hold of the missing BCD file. The main issue is that the error says the cause maybe a recent hardware change when I have had none since I bought my machine. So it has to be an internal relocation issue because when I ran chkdsk on the volume that consists of my OS, there were no corrupt files.

I also tried using the installation media to repair my system but it gives these same options as EFI/Dell/Boot/bootx64.efi, so that is no help either. I also tried re-installing windows 8 through the DVD. When it asks me to select a partition to install it in, I selected the one which had my C drive (442 GB). It gave an error that it is an ESP partition and that it cannot be used for the installation. Moreover, it did not let me select any partition except the one in which ubuntu is installed but even that cannot be used because the size is not enough.

I need help regarding these issues:

  1. is there any way to unlock the c drive and refresh my PC?

  2. Is there any automatic system restore point made when windows 8 to 8.1 update is done? If yes, then where is it stored and how can I access it?

  3. Is there a way I could access the missing BCD file and relocate it to the designated folder so that I can boot normally to my system?

  4. Any other solutions that anyone can offer to help me dual boot windows and ubuntu normally?

share|improve this question
    
Can you access the Windows installation drive from Ubuntu? That way you could backup your data in case you decide to try just resetting Windows 8. –  RPi Awesomeness Jan 30 at 13:20
    
I cannot access any data that was on my C: drive previously, from ubuntu. I am assuming that is because my C: drive is locked. So, no. I cannot backup the data. –  user241694 Jan 30 at 13:22

1 Answer 1

It may no be complete solution but you can recover your data from windows

Repairing windows boot loader

=> u need a windows 8 repair disc or windows 8 live usb or live cd

boot from any of the above windows disc and go to repair but not to use startup repair instead repair using windows command prompt

type the following two commands in cmd exactly

Bootrec/fixmbr 'press enter'

Bootrec/fixboot 'press enter'

now reboot u can see windows boot loader again

I hope that helps

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.