Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was a similar situation to this user: Dual Boot 10.10 and 11.04 can't boot into 10.10 after an update. Only many more GRUB entres.

Natty still worked - and I could still access the natty partition, until I ran sudo apt-get dist-upgrade to install a kernel update. Now trying to boot natty gives me a black screen. Booting into the same kernel in 'recovery mode' gets me a little further: Plymouth appears and pressing any key shows me that it's stuck at 'CUPS printing... OK'.

share|improve this question
try uninstalling the drivers..and then use another kernel to boot – Uri Herrera May 8 '11 at 18:37
@fossfreedom Thanks, removing that file worked :) – The Negative Shape May 9 '11 at 6:34
This question should instead be filed as a bug report, thanks! Instructions here. – Jorge Castro Apr 26 '12 at 21:36
up vote 7 down vote accepted

For Maverick users who have NVIDIA and/or ATI graphics together with activation of graphics drivers in the Additional Hardware Window are likely to suffer from the issue as described in the question. These drivers (especially nvidia) create a file called /etc/X11/xorg.conf. This file gives details about resolutions and describes the actual driver in use.

However, during the upgrade to Natty, the file remains in place - but the proprietary driver from NVIDIA is replaced by an open-source driver called nouveau. Since the file is still in place, the underlying graphics system called "X" still tries to invoke the old NVIDIA driver because its relying on the instructions in the xorg.conf file - the NVIDIA driver is not there resulting in black-screens etc.

For these users, the suggested route is to remove this file BEFORE upgrading.

However, this can be overcome by booting from a Live CD - the desktop CD.

Start a terminal and type

gksudo nautilus

then navigate to the folder /etc/X11/xorg.conf on your local hard-drive and either rename it or remove it.

share|improve this answer
there you go, +1 vote up – The Negative Shape May 10 '11 at 6:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.