Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed saucy as part of a dualboot setup. My laptop's internal network adaptor is shot and so I have to use an external D-Link DWA-123. I have the installation disc and everything and it works perfectly on windows. However, I cannot get it to work on Ubuntu. How can I go about doing so?

My lsusb output:

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 003: ID 0cf3:311d Atheros Communications, Inc.
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0c45:6458 Microdia
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 002: ID 0955:7100 NVidia Corp. Notion Ink Adam
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 2001:3310 D-Link Corp.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
share|improve this question
    
There are several revisions of this device. Please edit your question to add the result of the terminal command: lsusb –  chili555 Jan 30 at 14:28
    
Install usbutils and paste the output of usb-devices into your post. –  Braiam Feb 1 at 23:09

3 Answers 3

Type the following code in the console

sudo apt-get install git build-essential
git clone https://github.com/lwfinger/rtl8188eu
cd rtl8188eu
make all
sudo make install

remove previously manual installed modules eg:- sudo modprobe -r rtl8192cu

sudo modprobe 8188eu

Unplug , re-plug you should get going.

Tested on Dlink DWA-123 rev D1
Speedtest results : http://www.speedtest.net/my-result/3477686124

share|improve this answer
    
This saved my life :) Thank you so much –  Ravi Dhoriya ツ Jul 2 at 10:20

Your device seems to be recognized, plus the vendor of dwa-123 is actually RALINK. So maybe these instructions do work for you:

Check if kernel driver is loaded.

$ lsmod | grep rt2800usb

If the driver is not present load em:

$ sudo modprobe rt2800usb

To make changes permanent add

$ sudo sh -c 'echo "rt2800usb" >> /etc/modules'


@see:

share|improve this answer
    
This didn't work. Everytime i run the command ""rt2800usb" >> /etc/modules'" it returns permission denied –  user241691 Feb 1 at 12:32
    
Well /etc/modules is accessible by root only. Try sudo nano and then add rt2800usb at the end of the file. –  suqed Feb 1 at 12:46
    
I don't understand this... I tried sudo nano and it opens a blank file. What am I to put in it? –  user241691 Feb 1 at 13:18
    
You can find more information here: help.ubuntu.com/community/… –  suqed Feb 1 at 13:47
    
rt2800usb must be put at the end of this file. –  suqed Feb 1 at 13:53

Open a terminal (press Ctrl+Alt+t) and type the following command

rfkill list all

This will list the available wireless devices. Typing

rfkill unblock all

will unblock all wireless devices and

ifconfig wlan0 up

will bring device wlan0 up i.e. initialize the device and try to connect to the network using the current settings (assuming your wireless device is wlan0). For more information on the rfkill command you can type

man rfkill

to read the man page. (press q at any time to return to command shell)

If that doesn't help, install ceni

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.