Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I don't want to upgrade to the new release, and I don't want to have the notification icon about the upgrade (red triangle with exclamation mark in it) sit on the tray constantly.

share|improve this question
See also related question… for quelling the update notices in general, not only upgrades. –  Bryce Jun 27 '12 at 5:55

4 Answers 4

up vote 15 down vote accepted
  • Open Update Manages and click on Settings .

enter image description here

  • Go to Updates tab and change 'Show new distribution releases' to never.

enter image description here

share|improve this answer

In the 'Software Sources' go to 'Updates' tab and set 'Show New Distribution Releases' to 'Never' as shown below. I use Natty but it will be same in Lucid and Maverick too.


share|improve this answer

You should go to software center --> edit--> software sources

Then on the third tab (updates) go to "release upgrade" (last one) and change it to "never"

edit : what the others said above with glorious images :D

share|improve this answer

If you don't want to use the GUI, in Precise another way to do it is to edit /etc/update-manager/release-upgrades:

# Default behavior for the release upgrader.

# Default prompting behavior, valid options:
#  never  - Never check for a new release.
#  normal - Check to see if a new release is available.  If more than one new
#           release is found, the release upgrader will attempt to upgrade to
#           the release that immediately succeeds the currently-running
#           release.
#  lts    - Check to see if a new LTS release is available.  The upgrader
#           will attempt to upgrade to the first LTS release available after
#           the currently-running one.  Note that this option should not be
#           used if the currently-running release is not itself an LTS
#           release, since in that case the upgrader won't be able to
#           determine if a newer release is available.

Then change the last line to say:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.