Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My external 1TB hard drive is connected to the front USB2.0 socket on my 11.04 box. When copying files I have a very slow data transfer rate rate of approx. 12 MB/sec maximum even though from the hard disk utility it says it is connected at high-speed USB (480 MB/s):

enter image description here

This the output of lsusb:

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 046a:010a Cherry GmbH 
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 008: ID 1058:1001 Western Digital Technologies, Inc. External Hard Disk [Elements]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

This is the output of hdparm:

~$ sudo hdparm -Tt /dev/sdc1

 Timing cached reads:   1904 MB in  2.00 seconds = 952.06 MB/sec
 Timing buffered disk reads:  96 MB in  3.06 seconds =  31.35 MB/sec

With this rate it takes hours to backup my frequently edited large video files. This it makes it almost unusuable, even more so because I know it could perform much better.

Changing the USB port to another one on the back of the computer and changing the cable to a brand new one did not make any change.

Is there any setting I need to make in addition to defaults of my still quite vanilla but update 11.04 here?

share|improve this question
can you add to the question the results of the following: hdparm -Tt /dev/sdc1 – fossfreedom May 8 '11 at 16:50
also can you confirm that this issue isnt an IRQ issue - i.e. try to remove as many external devices, PCI cards. Alternatively try booting with either noapic or pci=routeirq in your kernel grub. – fossfreedom May 8 '11 at 16:52
By booting with pci=routeirq the drive made it up to 15 MB/s. – Takkat May 8 '11 at 20:26
up vote 4 down vote accepted

OK - font of all knowledge (!) wikipedia says that for a USB 2.0 interface, the theoretical maximum transfer rate is 480 Mbps (mega bits per second). Hence I think the Disk Utility is incorrectly overstating your USB drive - this should probably be filed as a bug.

I know there is an issue with NTFS, but from the screen-shot it looks like you are using EXT4, so this is not the issue.

The theoretical speed is max 60MB/s. However, I've read various reports such as this (also look at the transfer rate article in the wikipedia link) that state that you could expect half-of this rate. Thus, your drive is probably running as fast as it can.

For better speeds, use either a SATA II external disk or try a USB3.0 interface card + USB 3.0 External Hard-drive.

Suggest also confirm your drive rate using some command line tools as described here. It would be interesting to see how accurate Nautilus is reporting the transfer rate compared to the command line tools as per this link.

It is also worth booting with pci=routeirq in your kernel grub option - sometimes IRQ issues slow down hard-drive read/writes.

share|improve this answer
Thank you for the links. I am aware of the fact that the drive speed has actually nothing to do with the interface capabilities. However 12 - 15 MB/s still seems rather low to me. I do have an eSATA drive on the productive machine - sadly no hotplug there. I also connected the USB drive to my HD-TV-receiver that said it's at 24 MB/s there (on a FAT32 partition). – Takkat May 8 '11 at 20:32
Takkat - personnally, I have trusted the results of hdparm not what is reported by Nautilus. hdparm is reporting (31 MB/s) the same sort of values as wikipedia et al says your device can achieve. I've also added another link to give an alternative confirmation of the rate you should achieve. – fossfreedom May 8 '11 at 20:50
can you tell me about the NTFS issue please, I have the same hard drive and it is also very slow. – Marcel Oct 23 '11 at 20:46
NTFS is not native to the kernel - its part of ntfs-fuse which is magnitudes slower than native MS NTFS. The SO Question is relevant to you if you need to use NTFS but want better performance:… – fossfreedom Oct 23 '11 at 20:57

Correct me if I'm wrong but Megabytes are not the same as Megabits...

The USB 2.0 standard states speeds up to 480Mbps... that is a lower "b" which means bits...

Nautilus says you are moving data 12MBps, that is a capital B, which are bytes.

1 byte = 8 bits

12MB (megabytes) = 96Mb (megabits)

Besides, those speeds are "lab speeds" which means that they happened at the perfect circumstances but they always vary from hardware to hardware, much like the 56kbps modems never actually connected above 48kbps.

share|improve this answer
Still I had expected more than 12 MByte/s for a USB 2.0 drive. I accepted @fossfreedom's answer for pointing to Nautilus values that may underestimate the actual capability of the drive. – Takkat May 8 '11 at 22:05

I have similar problems after upgrading to Lubuntu 12.04 and had similar problems with Maverick.

After updating Maverick last summer the problem solved itself.

Now I cleaned my external hard drive with Gparted and reformatted it to ext4.

After that the first thing that happened is that I got no write access to the hard drive. Only after binding it into the system as owner I got access.

I find this really funny because it is an external hard drive and yes, I am the physical owner of them and they are just storage.

You do not have a problem with ownership on FAT32 partitions.

Transferring files from my computers hard drive to the external made me sad because I had no trouble with it before and now I got some invalid file name errors. Since I have the bad habit to play a simple game when I need to wait for tasks to finish I opened Majong and thought first this might be the reason for the trouble. Then I realized that the error might be related to a few files named in another language and changed the system language to repeat the procedure.

Guess what, it worked just fine.

Now the thing I would need help with is how to alter the USB problem that was fixed with Ubuntu 10.10 and Lubuntu 11.10.

The second would be just a simple answer to why I need to have ownership established for an ext4 formatted disk and might use any FAT32 or NTFS without such a need.

share|improve this answer

I expect it is a performance issues with NTFS. Is the USB disk partition you're working off NTFS formatted? What does your CPU look like while your copying these files?

If it is I would recommend not using NTFS on the USB disk unless you have to.

If you have to there is a known bug with NTFS-3G, though it doesn't list 11.04 as impacted. There is a comment that someone has confirmed it on 11.04, but anyway some people have had luck with an unofficial PPA though they have on packages for 11.04 yet.

Another fix may exist, if indeed this bug applies.

share|improve this answer
The disk is /ext4 formatted. – Takkat May 8 '11 at 20:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.