Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Does Ubuntu 11.04 (unity) not have a systray? I have set Show system tray icon to always in Pidgin's preferences, but nothing shows up. And it seems I can't add anything to the panel (is it even a gnome panel anymore?) -- otherwise I would have been able to add the systray applet myself.

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

The notification area in 11.04 only allows certain apps to appear there - you can whitelist more (or all) of them though through terminal. Pidgin, though, is not blacklisted, it just appears in the messaging menu (the little folder next to the clock)

share|improve this answer
    
Is there any way I can minimize it there? If I close it it exits completely, if I minimize it I'm stuck with two windows in the unity panel (the buddy list and the IM window). I only want the IM window. –  Felix May 8 '11 at 15:48
1  
If you have set the "show system tray icon"to always it shoudl minimize to the messaging menu on close, not exit. Try logging out and back in and/or disabling and reenabling the "show system tray icon" option –  Chriskin May 8 '11 at 15:51
    
I found at the ubuntu wiki that the "show system tray icon" doesn't work with the messaging menu - perhaps you should try to disable it in order for pidgin to work correctly. I'm not sure about this though, it's just an idea. –  Chriskin May 8 '11 at 15:57
    
Logging out/in did it. Now it appears in the tray and not in the messaging menu (which is perfect). Closing also minimizes to tray. –  Felix May 8 '11 at 16:31
add comment

You can find the answer here: How do I access and enable more icons to be in the system tray?. Personally I use scouser73's answer there.

share|improve this answer
    
The Pidgin icon is still not appearing. It does appear under the messaging menu, but that's not good enough. I want to be able to minimize Pidgin to the systray. I'm not currently able to do that (if I close the Pidgin window it exits). –  Felix May 8 '11 at 15:45
    
As answered by Chriskin, pidgin won't appear in systray. It just appears in the messaging menu and it certainly won't exit. You can bring it from messaging menu. –  Chethan S. May 8 '11 at 15:48
add comment

Be ware of unity systray issues. Whitelisting 'all' will help some while adversely impact anothers (Skype). There are some apps that are not compatible with unity systray - period (KeePassX). Most frustrating part is lack of consistency. Unity systray may behave one way in a current session, but on reboot(re-log) may unexpectedly change (resetting systray white list).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.