Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I run a netinstall of ubuntu 13.10. When I was on 12.10 I had a a sleep.sh script in /etc/acpid that would be invoked by the closelid event in /etc/acpid/events and then basically run pm-suspend.

I recently reinstalled the laptop and closing the lid put it to sleep even though I haven't yet installed my custom script.

What is causing the laptop to go to sleep then ?

share|improve this question
1  
That list is useless so I removed it. –  Rinzwind Jan 29 at 22:04
    
Thanks, I should have pruned it of non-essentials items. –  John Christopher Jan 30 at 10:14

1 Answer 1

up vote 1 down vote accepted

This is said to be a bug or weird feature in 13.10. To disable going into the sleep mode edit the /etc/systemd/logind.conf file and uncomment/modify/add the line:

HandleLidSwitch=ignore

Then execute sudo restart systemd-logind or simply reboot.

Also you might wanna check System Settings/Power and check the action not to suspend when lid is closed.

share|improve this answer
    
Note you can use sudo nano /etc/systemd/logind.conf to edit the file, you can get a manual with man logind.conf, and I may have accidentally posted this image, which you can embed by adding ![image](http://i.stack.imgur.com/U6xGB.png). Great Answer :D –  Wilf Jan 29 at 22:16
    
Editing /etc/systemd/logind.conf and replacing #HandleLidSwitch=suspend with HandleLidSwitch=ignore did it. Thank you. –  John Christopher Jan 29 at 23:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.