Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've seen many owners of Thinkpad Edges which are supposed to be Linux-friendly having problems with wireless adapter.

I've found several links inside askubuntu and in ubuntuforums which have a lot of workarounds for those problems, mine seems to be weird though.

I use my laptop on both my office and at home. At home I have a router which is A/B/G and here at home the wireless connection works just fine, using a WEP key.

But in work I have a B/G/N wireless router and it doesn't work, my guess is that this adapter works with N modes but somehow this is buggy in the bundled driver in natty. I've tried to disable the "N" mode in the router but that didn't work.

Later I went to Realtek website, downloaded their driver and compiled myself, kinda seems to work most of the time but sometimes some websites keep trying to load or load just parts of it and images start to look like their links are broken and so on, much like what you get when you were loading a page and suddenly the connection is lost. This problem, as I said, is only using the realtek driver from their website. dmesg gives me this a lot of these:

[ 5869.049454] rtl8192se_update_ratr_table: ratr_index=0 ratr_table=0x00000ff5
[ 5879.240563] DHCP pkt src port:68, dest port:67!!

So I thought I might as well switch back to the original driver which seems to work just fine on A/B/G wireless networks but not on N networks so if anybody knows how to disable that mode from within the driver please let us know :)

P.S. I did find a similar question, Wifi range issues and intermittent dropouts, Thinkpad Edge, and it was answered but let me remind you I'm not using the Intel version of wireless for my Thinkpad but the Realtek (RTL8192SvB).

share|improve this question
add comment

1 Answer

You can force your card to use specific wireless standard if the driver supports it with:

sudo iwconfig wlan0 modu 11g

Where wlan0 is your wireless interface and 11g the standard you want (802.11g in this case) .

Hopefully you won't be seeing:

SET failed on device wlan0 ; Operation not supported.
share|improve this answer
1  
Actually what I did was to disable the default driver, download the one from the realtek website and suddenly everything works ok, but thanks for the tip :) –  Gustavo Rubio Jun 23 '11 at 16:50
    
@Seppo Erviälä: Does iwconfig persist settings across reboots? The man page doesn't say. –  Mechanical snail May 27 '13 at 9:10
1  
@Mechanicalsnail You can put the command in your /etc/rc.local file and it gets run on reboot. –  Seppo Erviälä May 27 '13 at 18:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.