Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I start nvidia-settings in Terminal I get this, what can be the cause of this:

ERROR: Error querying target relations

The program 'nvidia-settings' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
(Details: serial 214 error_code 1 request_code 156 minor_code 29)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

I checked in Synaptic the version of Nvidia-settings installed is 331.20 nvidia-304-updates and recommended driver for my hardware is 304 could be because of this that I'm using newer nvidia-settings with an older driver installed? Should I install nvidia-settings 304? I ran --sync option provided in description but the error persists to appear. Tried to completely re-installed nvidia-settings and still the same, maybe it be developer's bug.

share|improve this question

closed as off-topic by user68186, Eric Carvalho, karel, Avinash Raj, BuZZ-dEE Feb 20 at 12:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – user68186, Eric Carvalho, karel, Avinash Raj, BuZZ-dEE
If this question can be reworded to fit the rules in the help center, please edit the question.

    
the bug has been fixed! Indeed, it was a bug in previous versions of Nvidia driver. There's no yet official fix in Ubuntu repository, the drivers version 304.116 and before provided by Ubuntu repos are still contain this bug. The bug fixed in driver version 304.119 released and provided by official Nvidia website. –  JohnnyEnglish Feb 19 at 19:27

protected by Community Feb 2 at 9:35

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.