Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to upload a package to ppa, but I get the error message (it is in the end of this post). I've created the ppa and tried to upload a signed package and I got the error. I thought that this is because I don't have my ssh key in the settings, so I've added one. But the problem is still here.

What should I do to upload my package to ppa?

bessarabov@bessarabov-note:~/tmp/delete_after_2011-05-08$ dput ppa:bessarabov/star libsql-easy-perl_0.02-1_i386.changes
Checking signature on .changes
gpg: Signature made Sun 08 May 2011 01:36:39 PM MSD using RSA key ID 79B2238B
gpg: Good signature from "Ivan Bessarabov "
Good signature on /home/bessarabov/tmp/delete_after_2011-05-08/libsql-easy-perl_0.02-1_i386.changes.
Checking signature on .dsc
gpg: Signature made Sun 08 May 2011 01:36:24 PM MSD using RSA key ID 79B2238B
gpg: Good signature from "Ivan Bessarabov "
Good signature on /home/bessarabov/tmp/delete_after_2011-05-08/libsql-easy-perl_0.02-1.dsc.
Uploading to ppa (via ftp to ppa.launchpad.net):
  Uploading libsql-easy-perl_0.02-1.dsc: done.
  Uploading libsql-easy-perl_0.02-1.tar.gz: done.
  Uploading libsql-easy-perl_0.02-1_all.deb: done.
  Uploading libsql-easy-perl_0.02-1_i386.changes: 1k/2k550 Changes file must be signed with a valid GPG signature: Verification failed 3 times: ["(7, 9, u'No public key')", "(7, 9, u'No public key')", "(7, 9, u'No public key')"] : Permission denied.
Note: This error might indicate a problem with your passive_ftp setting.
      Please consult dput.cf(5) for details on this configuration option.                                                                                bessarabov@bessarabov-note:~/tmp/delete_after_2011-05-08$
share|improve this question
    
Could be a bug/problem on launchpad itself: answers.launchpad.net/launchpad/+question/152715 (see comment #2). –  Rinzwind May 8 '11 at 12:07
add comment

1 Answer 1

The problem is solved. After adding my OpenPGP everything is ok.

More details on the discussion https://answers.launchpad.net/launchpad/+question/156588

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.