Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

ok so I want to use something like VNC or RDP to connect to my Ubuntu 12.04 server after it has booted up and is displaying a login prompt without having to go to the console and actually log in at the console first. I don't need to see the login screen that the console displays, but once it connects I'd like to be able to use the full desktop GUI.

This will be for admin management of the server, so it is ok if there is a single user/password for this access. It doesn't need to provide multiple concurrent access either, though that would be nice.

The machine was installed choosing "minimal" then running the commands

sudo apt-get install aptitude
sudo aptitude install screen openssh-server
sudo aptitude install --no-install-recommends ubuntu-desktop landscape-client-ui-install
sudo aptitude install indicator-application indicator-appmenu indicator-datetime indicator-session indicator-sound unity-lens-applications unity-lens-files xdg-utils

Now what?

I've tried

  • vino (aka "Desktop Sharing") seems to require that someone already be logged in to the server before it can be used.
  • tightvncserver says it can be run from the command line, but I must have been doing it wrong.
  • xrdp looks promising but just presents me with a blank window instead of a desktop when I log in
  • x11vnc with xvfb is complex and I only managed to create a VNC session from the ssh console of a terminal console.

Again, I seem to be missing something as there surely is a way, and possibly with the tools I've already tried.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

You should take a look on the X11RDP.

It's really a great update of the Xrdp in addition you can customize the behavior as u need. The guy there "Kevin Cave" is genius and now he make some update so you can install x11rdp as Debian packages.

Also you can use the regular xrdp with specifying ubuntu-2d as default session for xrdp. That should solve your problem with xrdp. To do that:

cd /home/user
echo "gnome-session --session=ubuntu-2d" > .xsession
sudo /etc/init.d/xrdp restart
share|improve this answer
    
I used the solution for ubuntu-2d with xrdp and that worked for me –  BeowulfNode42 Jan 29 at 7:50
    
@BeowulfNode42 Ok friend that's good. –  Ask Jan 29 at 7:51
    
I tried the same xrdp method on 14.04 and it no longer works. Will have to try x11rdp –  BeowulfNode42 May 24 at 4:54

Because Ubuntu 14.04 no longer includes ubuntu-2d as an option, so another is needed. Building on the answer by 'Ask' and the fact that I didn't feel like using something that wasn't in a deb package repository, for Ubuntu 14.04 I ended up doing

sudo aptitude --without-recommends install lxde menu-xdg
sudo aptitude install xrdp
echo "lxsession" > ~/.xsession
sudo service xrdp restart

Though, this does not give you a unity desktop, it does give you a nice gui desktop that is accessible with remote desktop with acceptable speed over a slow adsl2 link.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.