Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Built new computer:

AMD FX-8320 Eight-Core Processor × 8

9.7 GiB RAM

Graphics GeForce GTX 650 Ti BOOST/PCIe/SSE2

Ubuntu 13.10 64-bit

Desktop Computer

1 TB HardDrive

BIOS Type, UEFI

BIOS loaded first time I started up, configured. Then I ran the ubuntu cd I made. Installed, then all good. Now, I realized I cannot access the BIOS, at all, even when no hard drives are connected. I am pressing the right button, DEL. I have tired all the other keys on my keyboard, I know that is not the problem.

Other problem is that I took a hard drive with windows 7 on it from another computer, and put it in mine (Yes I installed it correctly). Grub does not detect it. I have updated Grub, used boot fixer, and a lot of other stuff. I think the key lies in the BIOS, if I could get to it, I think I could fix it myself

share|improve this question
    
So to sum it up: Ubuntu works and all problems are related to BIOS, UEFI and/or Windows? –  Rinzwind Jan 29 at 8:21
    
Is this a hard drive with Win7 (that is not being detected or booted) and Ubuntu (that can be booted)? What type of installation did You choose and what partition settings? Have You checked in Disk Manager if there is still Win7 partition? As I've typed, Win7 should not work properly on a different motherboard than it was installed on, I would backup Win7 data (access from Ubuntu for example) and then install freshly Win7, but this will cause another problem - most likely Win7 will disable Ubuntu booting, yet easy to solve, easy to search. –  Esamo Feb 1 at 2:35

2 Answers 2

This is a mess : ) ! And lack of information too (especially system configuration, notebook or not, one hard drive or more, live CD Ubuntu or installed one), but I'll try help.

This doesn't look like an Ubuntu problems, since it doesn't affect BIOS. Shouldn't at least.

Furthermore as far as I know currently Ubuntu 13 is a beta version and 12 is a released version. Beta version may be not a good choice while having additional problems.


The Hard Drive and opening BIOS options in UEFI

We are assuming that the hard drive isn't paralyzing the system, but it may be the case. Some system won't even enter BIOS with a broken drive, while (presumably) waiting for its' response. In that case

1) Can You enter BIOS without any hard drive?

2) If not, are You sure that Del key is working and You're fast enough with the pressing? It worked before using Ubuntu, right (sounds weird)?

3) If You're experienced and it won't cancel warranty, reset the BIOS settings manually (disconnect power source and computer's power battery, remove motherboard's battery for 30 sec and put it back in) which by the way commonly speeds the booting up and more. Risky for notebooks since those commonly have hidden batteries. Mean!

That pretty much is all I can think of having provided info and at this point You should have entered BIOS, know what is wrong or have other ideas.


Win7 GRUB detection

What I deducted is that You just took a hard drive with Win7 installed on it from one computer and put it into another. GRUB won't see Win7 until You tell it to, the easiest case is to run sudo update-grub at the terminal, but making sure that GRUB options are set correctly may be needed first. There is a plenty of GRUB help in this website and You're having the best info to find what You need. But even when Win7 will be detected it won't have installed drivers for it's new location - new computer, so it shouldn't work all nice, if at all. Because Windows is not meant to jump around different computers and not prepared to.

share|improve this answer
    
Updated information. –  Mac Hater Jan 31 at 21:15

BIOS

If You could enter BIOS at some point and You can no longer do that since changing its' settings, it seems obvious that some of Your changes made the problem. No idea what precisely, for example disabling 'USB Legacy/Support' will cause not responding USB keyboard until OS like Ubuntu will load itself with a keyboard driver. So just for cases like this, there is a way to...

Load default (or fail-safe) BIOS settings manually

Depending on the motherboard (check its' manual, printed or on the internet) there may be a jumper or a switch for this action, making the whole thing a lot easier (instruction in the manual), but if there is none:

  1. Disconnect all power supply from the turned off computer (required for staying alive during the process).
  2. Open the case and search for the round about half-inch diameter battery on the motherboard.
  3. Carefully take it off, maybe using a small, flat screwdriver (not making any damage to the board or the battery) - this will stop flow of current that powers 'remembering' the BIOS settings.
  4. Wait 30 seconds and put the battery back where it belongs on the motherboard - so any future BIOS changes will be remembered.
  5. Connect power supply to the computer and try entering BIOS by keyboard.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.