Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I couldn't install any software using apt-get command in my VPS and the terminal prints:

root@ubuntu:~# apt-get install python3
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package python3 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'python3' has no installation candidate

What's the problem? I've tried apt-get update as root user and here is what is shown to me:

root@ubuntu:~# apt-get update
Err precise-security Release.gpg
  Temporary failure resolving ''
Err precise Release.gpg
  Temporary failure resolving ''
Err precise-updates Release.gpg
  Temporary failure resolving ''
Err precise-backports Release.gpg
  Temporary failure resolving ''
Reading package lists... Done
W: Failed to fetch  Temporary failure resolving ''

W: Failed to fetch  Temporary failure resolving ''

W: Failed to fetch  Temporary failure resolving ''

W: Failed to fetch  Temporary failure resolving ''

W: Some index files failed to download. They have been ignored, or old ones used instead.

And my VPS place is in the Germany. Does it matter?

share|improve this question
Did you run the command "sudo apt-get update" ??? does that work? – Rat2000 Jan 28 '14 at 18:51
@Rat2000 Yes, I did and still doesn't work. – Hamid FzM Jan 28 '14 at 18:53
Possible Duplication of: apt-get update fails to fetch files – Achu Jan 28 '14 at 19:03
Thank's but if I change my DNS server does it make any problem for my websites running on my VPS? – Hamid FzM Jan 28 '14 at 19:20

1 Answer 1

up vote 2 down vote accepted

You have to fix your DNS resolver configuration, e.g the DNS server your own server is using to convert hostnames to IP addresses. This should not affect websites running on your VPS. Do not change DNS server your domains are using - that would break your websites.

You could either use your provider's DNS server (ask the settings from them, or check out their documentation), or for example Google's public DNS resolvers.

For instructions on how to change your DNS server, check out for example this question on

share|improve this answer
Thanks, I've tried CloaDNS and the server work fine. – Hamid FzM Jan 29 '14 at 20:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.