Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to the final release of ubuntu 11.04. Was previously running my laptop on ubuntu 10.04 which was perfectly fine. After the upgrade, I noticed the panels were missing. I did a unity --reset and everything came back. Now the issue is that the panels are not permanent, every time I start my pc, I have to do a unity --reset. Can this be sorted?

Ubuntu Level: Novice

share|improve this question
add comment

3 Answers 3

  • Open the dash by clicking on the top-left button (known as home button) or by pressing Super (the one with the windows sign) key and search for startup and open Startup Applications .

enter image description here

  • Now click on the add button .

enter image description here

  • Now enter a name in the name box and enter unity --replace in the command box.

enter image description here

  • Add it and you are done .
share|improve this answer
    
I don't necessarily think this answer deserves a downvote, but it definitely seems more like a workaround than a fix. –  michaelms May 27 '11 at 18:04
    
unity --reset resets all your options. You don't really want that running at every log-in, unless you're happy with sticking with default settings forever. –  Flimm May 30 '11 at 15:20
add comment

Who wants to reset unity on every computer start up???

I had similar problem. Not after upgrading Ubuntu but when I was messing up with Compiz. So I'd say Pranav has something like Cube enabled or something similar and that is messing up his Unity.

So first I would reset all Compiz to default values, and second make sure that Unity plugin is checked in Compiz.

share|improve this answer
add comment

This worked for me:

  1. Switch to tty1 (Ctrl+Alt+F1) and login as myself.
  2. rm -rf ~/.compiz (in order to recursively delete session logs... there might also be ~/compiz-1 and so on --> delete all!)
  3. sudo service lightdm restart
  4. login using the standard greeter again.

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/943083/comments/14

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.