Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got NVidia graphics and kubuntu 12.04 system. I've got 173 version of the driver installed currently and I try to install a newer driver (version 331 or 319). The beginning goes smoothly:

2014-01-28 16:43:46,588 DEBUG: install progress nvidia-331-updates 80.000000
2014-01-28 16:43:46,695 DEBUG: install progress nvidia-319-updates 80.000000
2014-01-28 16:43:46,763 DEBUG: install progress nvidia-319-updates 90.000000
2014-01-28 16:43:46,831 DEBUG: install progress nvidia-319-updates 100.000000
2014-01-28 16:43:49,338 DEBUG: Selecting previously unselected package nvidia-331-updates.
(Reading database ... 225012 files and directories currently installed.)
Unpacking nvidia-331-updates (from .../nvidia-331-updates_331.20-0ubuntu0.0.1_i386.deb) ...
Selecting previously unselected package nvidia-319-updates.
Unpacking nvidia-319-updates (from .../nvidia-319-updates_331.20-0ubuntu0.0.1_i386.deb) ...
Processing triggers for man-db ...
Setting up nvidia-331-updates (331.20-0ubuntu0.0.1) ...
INFO:Enable nvidia-331-updates
DEBUG:Parsing /usr/share/nvidia-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/nvidia-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/nvidia-common/quirks/put_your_quirks_here
Loading new nvidia-331-updates-331.20 DKMS files...
First Installation: checking all kernels...
Building only for 3.2.0-58-generic-pae
Building for architecture i686
Building initial module for 3.2.0-58-generic-pae
Done.

nvidia_331_updates:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-58-generic-pae/updates/dkms/

depmod....

DKMS: install completed.
Setting up nvidia-319-updates (331.20-0ubuntu0.0.1) ...

but eventually it fails all the time. /var/log/jockey.log contains the following (it's just the beginning):

2014-01-28 16:43:49,619 WARNING: modinfo for module nvidia_319_updates failed: ERROR: modinfo: could not find module nvidia_319_updates

2014-01-28 16:43:49,619 ERROR: XorgDriverHandler.enable(): package or module not installed, aborting
2014-01-28 16:43:49,627 ERROR: xorg:nvidia_319_updates: get_alternative_by_name(nvidia-319-updates) returned nothing
2014-01-28 16:43:49,714 DEBUG: NVidia(nvidia_319_updates).enabled(): target_alt None current_alt /usr/lib/nvidia-173/ld.so.conf other target alt None other current alt /usr/lib/nvidia-173/alt_ld.so.conf
2014-01-28 16:43:49,715 DEBUG: nvidia_319_updates is not the alternative in use
2014-01-28 16:43:49,745 DEBUG: NVidia(nvidia_319_updates).enabled(): target_alt None current_alt /usr/lib/nvidia-173/ld.so.conf other target alt None other current alt /usr/lib/nvidia-173/alt_ld.so.conf
2014-01-28 16:43:49,745 DEBUG: nvidia_319_updates is not the alternative in use
2014-01-28 16:43:55,091 DEBUG: NVidia(nvidia_173).enabled(): target_alt /usr/lib/nvidia-173/ld.so.conf current_alt /usr/lib/nvidia-173/ld.so.conf other target alt /usr/lib/nvidia-173/alt_ld.so.conf other current alt /usr/lib/nvidia-173/alt_ld.so.conf

Does anybody know what's going wrong?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.