Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using Xubuntu 13.10, X.Org X Server 1.14.5 and the lastest ATI drivers for my dual R9 270 setup. After some time (a few hours) Xorg starts to use 100% of one core (quad core intel CPU), the system becomes unstable and then stops.

Does anyone know of any patches or a fix for this situation?

I've found this on reddit:

This is because of an interrupt storm. This has been a problem with AMD drivers for over a year, and they have still not fixed it. The only fix if you experience this seems to go back to the 12.8 drivers, which is not humanely possible on Linux distros that ship a semi-recent version of all the Xorg software. (It's possible, but not worth it at all.) I had the same problem with later drivers on windows and Linux.

One last fix you can try is setting the affinity of the irq daemon to one core/thread, and limit bfg/cgminer to that core/thread too.

I don't know what how to achieve the last suggestion.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Solved using the taskset command:

taskset 0x00000001 command
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.