Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

VLC do not play any kind of video file. I will however start and stop correctly as open without any order to play anything. It used to work great before Ubuntu 12.04 reinstall, but now I face such strange problem.

Symptoms: - VLC do not play any kind of video. Just opens it and stays frozen on first second of file. - VLC opens an icon in notification bar just as it does regularly, but this time there is not an option to close it. Menu over there opens but do not respond. - At any attempt to play a video file VLC will open another "dead" icon in notification bar.

Attempts of solution:

  1. At first I thought it is lack of codecs, so I installed Ubuntu Restricted Extras. It did not work at all.
  2. I removed VLC .config folder and reinstalled VLC through apt-get install VLC. It did not work at all.
  3. I removed VLC through apt-get remove --purge VLC followed by apt-get autoremove, and reinstalled it using terminal. It did not work at all.

Problem stands and any of those attempts didn't fixed the issue.

share|improve this question

the first thing you could try is to add the VLC repository to get the latest version from: https://launchpad.net/~videolan/+archive/stable-daily

sudo apt-add-repository ppa:videolan/stable-daily
sudo apt-get update && sudo apt-get upgrade

(If this does not update to the lastest version. Do sudo apt-get purge and install again.)

Then you can try to install some additional codecs, see for instance this answer (about playing DVDs, but it might help): VLC won't run DVDs

sudo apt-get install ubuntu-restricted-extras
sudo apt-get install libdvdcss2 libdvdnav4 libdvdread4
sudo apt-get install libavformat-extra-53 libavcodec-extra-53 libdvdread4
sudo /usr/share/doc/libdvdread4/install-css.sh

Then restart and see.

share|improve this answer

Nothing had solved this issue. I followed your instructions but sadly it didn't worked out. I even reinstalled Ubuntu all over again to check if wiping out all possible configuration files would help, but sadly not. I think it could be connected with my Intel APU drivers. Those are cedarview drivers which was supported by Intel at the time of my first Ubuntu installation more than a year ago. Now there is no way to download they trough Additional Driver Manager ;(

share|improve this answer

I had a similar issue with VLC media player on my 32bit laptop with Xubuntu 14.04 LTS. So I have tried different approaches, here's what solved it:

First put in terminal:

sudo apt-get install ubuntu-restricted-extras
sudo apt-get install libdvdcss2 libdvdnav4 libdvdread4
sudo /usr/share/doc/libdvdread4/install-css.sh
sudo apt-get install libav-tools
sudo apt-get autoremove

Then restart your pc. Don't know if necessary but I did it.

Then remove mplayer (if you don't need it) and install the player "gxine".

Try out a video file in VLC. If still not working, open VLC and go to Tools>Preferences>Video. Make sure "Accelerated video output (Overlay)" and "Windows decorations" are checked. Look at "Output" and test all available options with a video that isn't working. See if you find an option that plays the video accurately. For me, it was "XVideoOutput (XCB)" but it could be a different one for your needs. You can leave the "Preferences" window open while testing. Videos should then also be working in gxine (don't ask me why, could be packages or removal of mplayer?).

To play encrypted DVDs look at this official site. Necessary packages are already included in code above.

Hope this works for you, too!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.