Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

VLC do not play any kind of video file. I will however start and stop correctly as open without any order to play anything. It used to work great before Ubuntu 12.04 reinstall, but now I face such strange problem.

Symptoms: - VLC do not play any kind of video. Just opens it and stays frozen on first second of file. - VLC opens an icon in notification bar just as it does regularly, but this time there is not an option to close it. Menu over there opens but do not respond. - At any attempt to play a video file VLC will open another "dead" icon in notification bar.

Attempts of solution:

  1. At first I thought it is lack of codecs, so I installed Ubuntu Restricted Extras. It did not work at all.
  2. I removed VLC .config folder and reinstalled VLC through apt-get install VLC. It did not work at all.
  3. I removed VLC through apt-get remove --purge VLC followed by apt-get autoremove, and reinstalled it using terminal. It did not work at all.

Problem stands and any of those attempts didn't fixed the issue.

share|improve this question

2 Answers 2

the first thing you could try is to add the VLC repository to get the latest version from: https://launchpad.net/~videolan/+archive/stable-daily

sudo apt-add-repository ppa:videolan/stable-daily
sudo apt-get update && sudo apt-get upgrade

(If this does not update to the lastest version. Do sudo apt-get purge and install again.)

Then you can try to install some additional codecs, see for instance this answer (about playing DVDs, but it might help): VLC won't run DVDs

sudo apt-get install ubuntu-restricted-extras
sudo apt-get install libdvdcss2 libdvdnav4 libdvdread4
sudo apt-get install libavformat-extra-53 libavcodec-extra-53 libdvdread4
sudo /usr/share/doc/libdvdread4/install-css.sh

Then restart and see.

share|improve this answer

Nothing had solved this issue. I followed your instructions but sadly it didn't worked out. I even reinstalled Ubuntu all over again to check if wiping out all possible configuration files would help, but sadly not. I think it could be connected with my Intel APU drivers. Those are cedarview drivers which was supported by Intel at the time of my first Ubuntu installation more than a year ago. Now there is no way to download they trough Additional Driver Manager ;(

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.