Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to make it so my laptop starts at a low brightness level, which is comfortable for my eyes and easy on the laptop's battery. I found some instructions here on AskUbuntu, and so by using this command:

cat /sys/class/backlight/intel_backlight/brightness

... I discovered that the maximum brightness is 4080 and the ideal brightness that I want to have my laptop default to is 700. So, I edited my /etc/rc.local file to have the following line in it:

echo 700 > /sys/class/backlight/acpi_video0/brightness

However, that didn't work. So, after a little more research, I tried this line:

echo 700 > /sys/class/backlight/intel_backlight/brightness

But that also changed nothing.

Now I'm a bit stuck. How do I get my brightness to start at the right level when I log in on my laptop?


Note: It seems that this problem may be made worse by another more general issue of commands not running at startup, which I've asked about in a separate question. I think some of the answers suggested so far may actually work in principle, but I can't verify any of them unless I'm sure my startup programs are executing at all.

share|improve this question
1  
Did you tried updating the GRUB parameter? Screen brightness not working –  Web-E Feb 2 at 6:21
1  
Does xbacklight work? –  Mahesh Feb 2 at 6:21
    
did you add those commands ##above## exit 0 in rc.local? can you post your rc.local file? –  virtualxtc Feb 3 at 4:12
    
@virtualxt, yes, the commands were above the exit 0. At the moment, I have reset my rc.local file back to default since nothing was working anyway. –  Dave M G Feb 3 at 7:01
    
Have you tried using Ubuntu's auto start GUI instead of rc.local? askubuntu.com/questions/48321/… –  virtualxtc Feb 3 at 7:05

6 Answers 6

I had the same issue.

Solution = xbacklight:

Install xbacklight:

sudo apt-get install xbacklight

Then add "xbacklight -set x" (where 'x' = 0 to 100 desired brightness) to the startup applications via dashboard. For example, xbacklight -set 50.

This works with UX32VD and UX31A Asus Ultrabooks.

share|improve this answer
    
Thank you for this suggestion. I installed xbacklight and if I run xbacklight -set 5 it sets my screen to the desired brightness level. But if I at xbacklight -set 5 to my startup applications, it has no effect. My screen still defaults to maxiumum brightness on login. –  Dave M G Feb 3 at 7:00
1  
Do you have the command placed in the "command" and not in the "name" inputs of the startup program? Can you post a photo? –  Brandex Feb 5 at 19:25

First let us check yiour VGA device code

lspci | grep VGA

The device code looks like 00:03.0 for example.

To set brightness

sudo setpci -s '00:03.0' F4.B='xy'

where 00:03.0 is your VGA device code && xy is hexadecimal value of your screen brightness varies between 00 and FF.


EDIT:You can try this also..

first know the output name

xrandr -q

for example my output name is DVI-I-2

The brightness can be changed like this:

xrandr --output DVI-I-2 --brightness 1

Now add this command to your startup programs or to the /etc/rc.local file.

share|improve this answer
    
Thank you for this suggestion. My device code is 00:02.0. I used the command sudo setpci -s '00:02.0' F4.B='FF' to set my brightness to maximum as a test. There was no response or change in my brightness. –  Dave M G Feb 3 at 11:26
    
Check my update edit –  Ask Feb 3 at 12:14

I found this: LINK

As to avoid issues with dead links, I will add it here as well. :)

  1. Open a terminal window.

  2. Type in the following commands then hit Enter after each.

    sudo apt-get install xbacklight

  3. Open the Startup Applications Preferences menu.

  4. Click the Add button and add the following information:

    Name: Brightness Command: xbacklight -set 60

  5. Replace 60 with whatever brightness level you prefer.

And of course, credit where credit is due:

Jim Lynch for the blog post with the answer. :)

share|improve this answer
sudo apt-get install xbacklight

To run on startup

on unity dash search for startup applications and enter name and the command

xbacklight -set XXX

Replace XXX by the appropriate value

share|improve this answer

Try this, it works for me.

sudo sh -c "echo $VAL > /sys/class/backlight/acpi_video0/brightness"

where, $VAL ranges from 0-100(lowest-to-highest)

Example

sudo sh -c "echo 7 > /sys/class/backlight/acpi_video0/brightness"

SOURCE : Setting a display's backlight brightness to be lower than is possible via the normal brightness controls

share|improve this answer
up vote 0 down vote accepted

In the end it turned out that there was a conflict with the power management preferences. The default brightness setting for when my laptop is on AC power is somehow over riding the default for when the laptop is on battery power. I've determined that if I uninstall all power management tools, then any of the commands suggested in the other answers will work.

In order to have the optimal system, I need to figure out how to get power management and screen adjustments to play nicely together, but that is a different journey from this question.

The lesson learned here, though, is that when dealing with screen brightness, or other startup commands, there may be multiple commands exerting an influence. So one necessary step in solving the problem is to try and determine all the relevant programs that might be having an impact.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.