Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So a file server with a AMD APU A8-6600k that has been used as a headless box for awhile but i am now going to be using a screen for messing with steam game streaming. So figured i would install the AMD graphics drivers.

I initially went to their website downloaded the latest zip file, unzipping it produced a .run file. I then proceeded to run a sh amd-file-name.run This brought me into a series of menus that failed.

Ok i then realize i should probably find some sort of guide. So i followed both

https://help.ubuntu.com/community/BinaryDriverHowto/AMD

and

What is the correct way to install ATI Catalyst Video Drivers (fglrx)?

I eventually assumed that the deb files were missing dependencies so i ran a

sudo apt-get -f install 

This tells me i am going to install fglrx however i get the following error.

[Warning] Uninstall : inst_path_default or inst_path_override
does not exist in /etc/ati.  This suggests that the AMD driver
is not installed, the AMD driver is only partially installed,
or the current AMD driver installed is an older version than the
one this script was designed for.  Both files listed above are
required for determining where installed files are located.
To force uninstallation of the driver by guessing where the
uninstallation files are located, set the force option
re-run /usr/share/ati/fglrx-uninstall.sh (this is not recommended).

dpkg: error processing /var/cache/apt/archives/fglrx_2%3a13.101-0ubuntu3_amd64.deb (--unpack):
subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/fglrx_2%3a13.101-0ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I am at a total loss as to where to proceed and have now any gui, and just receive a black screen.

Should i run the uninstall even though it says its not recommended?

share|improve this question
add comment

1 Answer

We have the same problem and same specs (AMD A8-6600k with radeon HD8570D) and yes, unistalling the driver and deleting xorg.conf file helps you restoring the GUI, but i have no clue how to make those drivers work (I asked a similar question some hours ago).

share|improve this answer
    
Well im glad im not alone, however i have a feeling im to messed up at this point to restore my gui without going forward. I may or maynot have forgot to make a backup of anything before i started. Did you just remove the file? –  user2008251 Jan 28 at 1:26
    
go in failsafe mode and: 1) sh /usr/share/ati/fglrx-uninstall.sh 2) apt-get remove --purge fglrx* 3) rm /etc/X11/xorg.conf and reboot. Hope to find a solution for this driver issue someday... –  Violet Jan 28 at 20:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.